Welcome

Welcome to the Control Center SDK Guide. This is intended as a reference that you can use to find out all you need to know about creating applications to manage Control Center without human interaction.

Help contents

This help is composed by two main parts:

  • The getting started tutorial, along with common examples.

  • The list of all classes, at ControlCenterSDK namespace.


Getting started

The topics in this section will help you install all of the required tools, become familiar with the Control Center SDK, and create your first project.

  • Walktrough: Creating your first project

  • Control Center SDK overview


Walktrough: Creating your first project

This tutorial presents a step-by-step guide on how to setup a basic application that uses Control Center SDK.

Prerequisites

To develop an application using Control Center SDK, you need an installation of Control Center version 5 or greater, an installation of Visual Studio 2010 or greater and .Net Framework version 4 or greater.

Note Note

The applications created by using Control Center SDK need that Control Center is installed, in order to execute (i.e. the application is not self-contained). So, if your applications are deployed in a machine other than the one used to develop them, you need first to install Control Center. You have to use the same version of Control Center used to develop the application.

Note Note

Control Center SDK is built for 32 bits architectures. If you have a 64 bits machine, you need to manually specify in your build configuration to generate 32 bits code, because "Any CPU" configuration is not currently supported. See How to build for 32 bits architecture.

Create a new application

  1. Open Visual Studio and create a new project by selecting "File > New > Project" menu.

  2. Select the Visual C# Console Application project template, give a name and a location to the project. Select the .Net Framework 4 as target framework and press OK.

  3. Inside the Solution Explorer of Visual Studio, right click on the project and select "Add > Reference".

  4. Under "Assemblies Extensions", select Control Center SDK and press OK.

  5. Now "ControlCenterSDK.dll" has been added to the project references and you can see it under the "References" node in the Solution Explorer. Select "ControlCenterSDK.dll" and set the property "Copy Local to "False" in the Properties panel.

  6. In the properties of "ControlCenterSDK.dll", there is the property "Specific Version". Set this property to "False", to enable updates of the SDK when a new version of Control Center is installed. If this porperty is set to "True", all the machines in which your application will be deployed must install the same version of Control Center that you used to develop the application.

  7. If you are on a 64 bits platform, you have to manually specify to build your application for 32 bits architecture. See How to build for 32 bits architecture.

You can now use the API provided by ControlCenterSDK to create your application.

How to build for 32 bits architecture

If you have a 64 bits machine, you need to build your application against 32 bits architecture, in order to use Control Center SDK.

Change build platform in Visual Studio

  1. Inside the Solution Explorer of Visual Studio, right click on the project and select "Properties".

  2. In "Build" tab, change the "Platform target" to "x86". Change this settings for all the configurations (i.e. "Debug" and "Release").

See Also

Reference

ControlCenterSDK

Other Resources

Examples


Control Center SDK overview

An application can use Control Center SDK to automate some manual operations that can be done with the Control Center application. Here is overview of the main functionalities and some important remarks.

Main functionalities

The main classes of Control Center SDK are Domain, which provides access to a domain with browsing capabilities (folders and devices); Device, which provides services for an online device, such as the VPN, Serial passtrough, data monitor, file transfer and processes management.

To browse a domain you have to connect to it with username and password. Permissions on the user are applied in the same way as Control Center application does. You can iterate all over the domain by looking for devices (see Browse domain to view an example) and view their properties or connect to them. To connect to a device you have to retrieve it by iterating the domain or finding it by using a full path (folder names plus device name) and then call the DomainConnectDevice(DeviceInfo) method with the given DeviceInfo object.

Once you have a Device, you can connect some of its services, by using its properties. You can find VPN that is the VPN service; Management that provides access to file transfer and remote processes management functionalities, and other services. Every service can be connected and disconnected on demand, by using their memeber functions Connect and Disconnect. Every service has also properties that are used to retreive informations or change settings. Changes to the settings are effective only when the service is started. So, if you want to change settings of a connected service you must disconnect and reconnect it.

Implementation issues

The Control Center SDK uses Dispose pattern. To make sure resources are cleaned up properly, you should use the try-finally construct or the using statement.

Important note Important

If the application fails to disconnect or dispose a connected device, it will stay connected, until the application or the device are terminated. Similarly, if the application connects to a domain and fails to disconnect or dispose it, it will stay connected until the application is terminated. If it happens, you cannot connect to other domains since the application is restarted, because there can be only one connected domain at a time.

You can use the following snippet of code as an example on how to safely connect to a domain and to a device. This example makes use of the using statement to be sure that domain and device are disconnected even in the presence of exceptions.

C#
Copy
// initialize the Domain object with the name of the domain
using (Domain myDomain = new Domain("MyOrganizationDomain"))
{
    // connect to the domain with an user and a password
    myDomain.Connect("user", "password");
    // get informations about device "Machine1", into folder "Italy"
    DeviceInfo deviceInfo = myDomain.GetDevice(@"Italy\Machine1");

    // connect to the device
    using (Device deviceServices = myDomain.ConnectDevice(deviceInfo))
    {
        // you can use here a connected device
    }
    // device is automatically disconnected here
}
// domain is automatically disconnected here
See Also

Reference

ControlCenterSDK

Other Resources

Examples


Examples

Here is a list of examples that cover the most common functionalities provided by Control Center SDK:

  • Download files

  • Browse domain

  • VPN connection

  • Data monitor


Download files

This is a basic example showing how to connect to a machine located in a known path in the domain and download a file.

Example
C#
Copy
using ControlCenterSDK;
using System;
using System.Diagnostics;

namespace MyApp
{
    class Program
    {
        static void Main(string[] args)
        {
            // initialize the Domain object with the name of the domain
            using (Domain myDomain = new Domain("MyOrganizationDomain"))
            {
                // connect to the domain with an user and a password
                myDomain.Connect("user", "password");
                // get informations about device "Machine1", into folder "Italy"
                DeviceInfo deviceInfo = myDomain.GetDevice(@"Italy\Machine1");
                // the name of the device is "Machine1"
                Debug.Assert(deviceInfo.Name == "Machine1");
                // connect to the device
                using (Device deviceServices = myDomain.ConnectDevice(deviceInfo))
                {
                    // download two files from a remote folder
                    deviceServices.Management.Connect();
                    // overwrite destination files if present
                    deviceServices.Management.DefaultExistingFileBehavior = FileTransferBehavior.Overwrite;

                    string[] files = new string[]
                    {
                        "file1",
                        "file2"
                    };
                    // the remote folder is C:\MyApp
                    // download file1, file2 inside that folder
                    // put them into the local folder LocalFolder\Downloads
                    deviceServices.Management.Download(@"C:\MyApp", files, @"LocalFolder\Downloads");
                    deviceServices.Management.Disconnect();
                }
                // device is automatically disconnected here
            }
            // domain is automatically disconnected here
        }
    }
}
See Also

Reference

Domain
DomainConnectDevice(DeviceInfo)
ManagementServiceDownload


Browse domain

This example shows how to connect to a domain, browse first level folders and get informations about devices inside them.

Example
C#
Copy
using ControlCenterSDK;
using System;
using System.Collections.Generic;

namespace MyApp
{
    class Program
    {
        static void Main(string[] args)
        {
            // initialize the Domain object with the name of the domain
            using (Domain domain = new Domain("MyOrganizationDomain"))
            {
                // connect to the domain with an user and a password
                domain.Connect("user", "password");

                // you can use one of the following implementations
                BrowseDomainByFolders(domain);
                BrowseDomainForAllDevices(domain);

                // there are additional possibilities: take a look
                // at the Domain reference documentation for details
            }
            // domain is automatically disconnected here
        }

        // you can use this version if you want to scan devices ordered
        // by their containing folder
        static void BrowseDomainByFolders(Domain domain)
        {
            // get the root folders
            List<FolderInfo> folders = domain.GetFolders();
            foreach (FolderInfo f in folders)
            {
                Console.WriteLine("Current folder: " + f.Name);
                // get all the devices inside that folder or subfolders
                List<DeviceInfo> devices = domain.GetDevices(f, true);
                foreach (DeviceInfo d in devices)
                {
                    // dump online devices
                    if (d.IsOnline)
                        Console.WriteLine("  - " + d.Name + " is online");
                }
            }
        }

        // you can use this version if you want to scan all the devices without
        // caring about domain folders
        static void BrowseDomainForAllDevices(Domain domain)
        {
            // get all the devices in the domain
            List<DeviceInfo> devices = domain.GetDevices();
            foreach (DeviceInfo d in devices)
            {
                // dump online devices
                if (d.IsOnline)
                    Console.WriteLine("  - " + d.Name + " is online");
            }
        }
    }
}
See Also

Reference

Domain
DeviceInfo
DomainGetFolders(String)
DomainGetDevices(FolderInfo, Boolean)


VPN connection

This example shows how to connect the VPN to a device, by using a static local IP, or an automatically assigned one.

Example
C#
Copy
using ControlCenterSDK;
using System;
using System.Diagnostics;

namespace MyApp
{
    class Program
    {
        static void Main(string[] args)
        {
            // initialize the Domain object with the name of the domain
            using (Domain domain = new Domain("MyOrganizationDomain"))
            {
                // connect to the domain with an user and a password
                domain.Connect("user", "password");
                Console.WriteLine("Connected");
                // connect to a device
                using (Device d = domain.ConnectDevice(domain.GetDevice(@"Test\TestDevice")))
                {
                    Console.WriteLine("Device connected");
                    // you can use one of the following implementations
                    ConnectUsingDefaultSettings(d);
                    ConnectUsingAutomaticIp(d);
                    ConnectUsingManualIp(d);
                }
                // device is automatically disconnected here
            }
            // domain is automatically disconnected here
            Console.WriteLine("Disconnected");
        }

        // this is the default (and most recommended) way to connect the
        // VPN to a device
        static void ConnectUsingDefaultSettings(Device device)
        {
            // no setup of VPN properties
            // the settings are taken from current Control Center configuration
            device.VPN.Connect();
            // you can use here the VPN
            PrintIpAddressInfo(device);
            // ...
            device.VPN.Disconnect();
        }

        // overwrite Control Center settings and set the IP assignment
        // mode to automatic.
        // in this way, the local ip is assigned by the remote device,
        // by looking at free IPs in the remote network.
        static void ConnectUsingAutomaticIp(Device device)
        {
            // use this only if you want to overwrite settings used
            // by Control Center for the current device
            device.VPN.LocalVPNAddressAssignmentMode = IPAssignmentMode.Automatic;

            // connect the VPN
            device.VPN.Connect();
            // you can use here the VPN
            PrintIpAddressInfo(device);
            // ...
            device.VPN.Disconnect();
        }

        // overwrite Control Center settings and set the IP assignment
        // mode to manual.
        // in this way, the local ip is assigned by hand.
        static void ConnectUsingManualIp(Device device)
        {
            // use this only if you want to overwrite settings used
            // by Control Center for the current device.
            // you can statically assign an IP address to be used for the
            // local endpoint during VPN connection
            device.VPN.DesiredLocalVPNAddresses.Clear();
            device.VPN.DesiredLocalVPNAddresses.Add(new AddressAndMask("10.8.0.7", "255.255.0.0"));
            device.VPN.LocalVPNAddressAssignmentMode = IPAssignmentMode.Manual;

            // connect the VPN
            device.VPN.Connect();
            // you can use here the VPN
            PrintIpAddressInfo(device);
            // ...
            device.VPN.Disconnect();
        }

        // print debug informations
        static void PrintIpAddressInfo(Device device)
        {
            // print some informations about VPN IP addresses of local PC
            Console.WriteLine("Connected VPN");
            Console.WriteLine("My IP addresses: ");
            foreach (AddressAndMask addr in device.VPN.LocalVPNAddresses)
                Console.WriteLine(addr.Address.ToString());

            // and remote device
            Console.WriteLine("Device VPN IP addresses: ");
            foreach (AddressAndMask addr in device.Info.ReachableIPAddresses)
                Console.WriteLine(addr.Address.ToString());
        }
    }
}
See Also

Reference

DeviceInfo
VPNService


Data monitor

This example shows how to connect to a device and download logs from the data monitor application.

Example
C#
Copy
using ControlCenterSDK;
using System.Collections.Generic;
using System.IO;

namespace MyApp
{
    class Program
    {
        static void Main(string[] args)
        {
            // initialize the Domain object with the name of the domain
            using (Domain myDomain = new Domain("MyOrganizationDomain"))
            {
                // connect to the domain with an user and a password
                myDomain.Connect("user", "password");
                // get informations about device "Machine1", into folder "Italy"
                DeviceInfo deviceInfo = myDomain.GetDevice(@"Italy\Machine1");
                // connect to the device
                using (Device deviceServices = myDomain.ConnectDevice(deviceInfo))
                {
                    // create the destination folder
                    string destFolder = @"C:\Users\Administrator\Desktop\Logs";
                    if (!Directory.Exists(destFolder))
                        Directory.CreateDirectory(destFolder);

                    // use one of the following implementations
                    DownloadAllLogs(deviceServices, destFolder);
                    DownloadSomeLogs(deviceServices, destFolder);
                }
                // device is automatically disconnected here
            }
            // domain is automatically disconnected here
        }

        static void DownloadAllLogs(Device device, string destFolder)
        {
            device.DataMonitor.Connect();
            // export all the logs available into the given local folder
            device.DataMonitor.ExportLogs(destFolder);
            device.DataMonitor.Disconnect();
        }

        static void DownloadSomeLogs(Device device, string destFolder)
        {
            device.DataMonitor.Connect();

            // create the list of logs from the current available logs
            var logsToExport = new List<DataMonitorService.LogEntry>();
            foreach (DataMonitorService.LogEntry entry in device.DataMonitor.DataLogList)
            {
                if (entry.Name == "DataLogger1")
                    logsToExport.Add(entry);
            }
            foreach (DataMonitorService.LogEntry entry in device.DataMonitor.HistoricalLogList)
            {
                if (entry.Name == "SysMsgs")
                    logsToExport.Add(entry);
            }

            // export only the selected logs
            device.DataMonitor.ExportLogs(destFolder, logsToExport);
            device.DataMonitor.Disconnect();
        }
    }
}
See Also

Reference

DataMonitorService


Reference Manual

Namespaces
Namespace | Description
ASEM.Common |
ControlCenterSDK | This namespace contains all the classes of Control Center SDK.


ASEM.Common Namespace

[Missing <summary> documentation for "N:ASEM.Common"]

Classes
 | Class | Description
Public class | ASEMVersion |
Public class | ClientVersion |


ASEMVersion Class

[Missing <summary> documentation for "T:ASEM.Common.ASEMVersion"]

Inheritance Hierarchy
SystemObject
ASEM.CommonASEMVersion

Namespace: ASEM.Common
Assembly: ControlCenterSDK (in ControlCenterSDK.dll) Version: 11.3.30.0 (11.3.030)
Syntax
C#
Copy
public class ASEMVersion : IEquatable<ASEMVersion>

The ASEMVersion type exposes the following members.

Constructors
 | Name | Description
Public method | ASEMVersion(Int64) | Initializes a new instance of the ASEMVersion class
Public method | ASEMVersion(ClientVersion) | Initializes a new instance of the ASEMVersion class
Public method | ASEMVersion(Int32, Int32, Int32, Int32) | Initializes a new instance of the ASEMVersion class
Top
Properties
 | Name | Description
Public property | Build |
Public property | Major |
Public property | Minor |
Public property | Revision |
Top
Methods
 | Name | Description
Public method | Equals(Object) | (Overrides ObjectEquals(Object).)
Public method | Equals(ASEMVersion) |
Public method | GetHashCode | (Overrides ObjectGetHashCode.)
Public method | ToNumber |
Public method | ToString | (Overrides ObjectToString.)
Top
See Also

Reference

ASEM.Common Namespace


ASEMVersion Constructor

Overload List
 | Name | Description
Public method | ASEMVersion(Int64) | Initializes a new instance of the ASEMVersion class
Public method | ASEMVersion(ClientVersion) | Initializes a new instance of the ASEMVersion class
Public method | ASEMVersion(Int32, Int32, Int32, Int32) | Initializes a new instance of the ASEMVersion class
Top
See Also

Reference

ASEMVersion Class
ASEM.Common Namespace


ASEMVersion Constructor (Int64)

Initializes a new instance of the ASEMVersion class

Namespace: ASEM.Common
Assembly: ControlCenterSDK (in ControlCenterSDK.dll) Version: 11.3.30.0 (11.3.030)
Syntax
C#
Copy
public ASEMVersion(
    long version
)

Parameters

version
Type: SystemInt64

[Missing <param name="version"/> documentation for "M:ASEM.Common.ASEMVersion.#ctor(System.Int64)"]

See Also

Reference

ASEMVersion Class
ASEMVersion Overload
ASEM.Common Namespace


ASEMVersion Constructor (ClientVersion)

Initializes a new instance of the ASEMVersion class

Namespace: ASEM.Common
Assembly: ControlCenterSDK (in ControlCenterSDK.dll) Version: 11.3.30.0 (11.3.030)
Syntax
C#
Copy
public ASEMVersion(
    ClientVersion clientVersion
)

Parameters

clientVersion
Type: ASEM.CommonClientVersion

[Missing <param name="clientVersion"/> documentation for "M:ASEM.Common.ASEMVersion.#ctor(ASEM.Common.ClientVersion)"]

See Also

Reference

ASEMVersion Class
ASEMVersion Overload
ASEM.Common Namespace


ASEMVersion Constructor (Int32, Int32, Int32, Int32)

Initializes a new instance of the ASEMVersion class

Namespace: ASEM.Common
Assembly: ControlCenterSDK (in ControlCenterSDK.dll) Version: 11.3.30.0 (11.3.030)
Syntax
C#
Copy
public ASEMVersion(
    int major,
    int minor,
    int revision,
    int build
)

Parameters

major
Type: SystemInt32

[Missing <param name="major"/> documentation for "M:ASEM.Common.ASEMVersion.#ctor(System.Int32,System.Int32,System.Int32,System.Int32)"]

minor
Type: SystemInt32

[Missing <param name="minor"/> documentation for "M:ASEM.Common.ASEMVersion.#ctor(System.Int32,System.Int32,System.Int32,System.Int32)"]

revision
Type: SystemInt32

[Missing <param name="revision"/> documentation for "M:ASEM.Common.ASEMVersion.#ctor(System.Int32,System.Int32,System.Int32,System.Int32)"]

build
Type: SystemInt32

[Missing <param name="build"/> documentation for "M:ASEM.Common.ASEMVersion.#ctor(System.Int32,System.Int32,System.Int32,System.Int32)"]

See Also

Reference

ASEMVersion Class
ASEMVersion Overload
ASEM.Common Namespace


ASEMVersion Properties

The ASEMVersion type exposes the following members.

Properties
 | Name | Description
Public property | Build |
Public property | Major |
Public property | Minor |
Public property | Revision |
Top
See Also

Reference

ASEMVersion Class
ASEM.Common Namespace


ASEMVersion.Build Property

Control Center SDK Documentation

ASEMVersionBuild Property

[Missing <summary> documentation for "P:ASEM.Common.ASEMVersion.Build"]

Namespace: ASEM.Common
Assembly: ControlCenterSDK (in ControlCenterSDK.dll) Version: 11.3.30.0 (11.3.030)
Syntax
C#
Copy
public int Build { get; set; }

Property Value

Type: Int32
See Also

Reference

ASEMVersion Class
ASEM.Common Namespace


ASEMVersion.Major Property

ASEMVersionMajor Property

[Missing <summary> documentation for "P:ASEM.Common.ASEMVersion.Major"]

Namespace: ASEM.Common
Assembly: ControlCenterSDK (in ControlCenterSDK.dll) Version: 11.3.30.0 (11.3.030)
Syntax
C#
Copy
public int Major { get; set; }

Property Value

Type: Int32
See Also

Reference

ASEMVersion Class
ASEM.Common Namespace


ASEMVersion.Minor Property

ASEMVersionMinor Property

[Missing <summary> documentation for "P:ASEM.Common.ASEMVersion.Minor"]

Namespace: ASEM.Common
Assembly: ControlCenterSDK (in ControlCenterSDK.dll) Version: 11.3.30.0 (11.3.030)
Syntax
C#
Copy
public int Minor { get; set; }

Property Value

Type: Int32
See Also

Reference

ASEMVersion Class
ASEM.Common Namespace


ASEMVersion.Revision Property

ASEMVersionRevision Property

[Missing <summary> documentation for "P:ASEM.Common.ASEMVersion.Revision"]

Namespace: ASEM.Common
Assembly: ControlCenterSDK (in ControlCenterSDK.dll) Version: 11.3.30.0 (11.3.030)
Syntax
C#
Copy
public int Revision { get; set; }

Property Value

Type: Int32
See Also

Reference

ASEMVersion Class
ASEM.Common Namespace


ASEMVersion Methods

The ASEMVersion type exposes the following members.

Methods
 | Name | Description
Public method | Equals(Object) | (Overrides ObjectEquals(Object).)
Public method | Equals(ASEMVersion) |
Public method | GetHashCode | (Overrides ObjectGetHashCode.)
Public method | ToNumber |
Public method | ToString | (Overrides ObjectToString.)
Top
See Also

Reference

ASEMVersion Class
ASEM.Common Namespace


ASEMVersion.Equals Method

ASEMVersionEquals Method

Overload List
 | Name | Description
Public method | Equals(Object) | (Overrides ObjectEquals(Object).)
Public method | Equals(ASEMVersion) |
Top
See Also

Reference

ASEMVersion Class
ASEM.Common Namespace


ASEMVersion.Equals Method (Object)

ASEMVersionEquals Method (Object)

[Missing <summary> documentation for "M:ASEM.Common.ASEMVersion.Equals(System.Object)"]

Namespace: ASEM.Common
Assembly: ControlCenterSDK (in ControlCenterSDK.dll) Version: 11.3.30.0 (11.3.030)
Syntax
C#
Copy
public override bool Equals(
    Object obj
)

Parameters

obj
Type: SystemObject

[Missing <param name="obj"/> documentation for "M:ASEM.Common.ASEMVersion.Equals(System.Object)"]

Return Value

Type: Boolean

[Missing <returns> documentation for "M:ASEM.Common.ASEMVersion.Equals(System.Object)"]

See Also

Reference

ASEMVersion Class
Equals Overload
ASEM.Common Namespace


ASEMVersion.Equals Method (ASEMVersion)

ASEMVersionEquals Method (ASEMVersion)

[Missing <summary> documentation for "M:ASEM.Common.ASEMVersion.Equals(ASEM.Common.ASEMVersion)"]

Namespace: ASEM.Common
Assembly: ControlCenterSDK (in ControlCenterSDK.dll) Version: 11.3.30.0 (11.3.030)
Syntax
C#
Copy
public bool Equals(
    ASEMVersion other
)

Parameters

other
Type: ASEM.CommonASEMVersion

[Missing <param name="other"/> documentation for "M:ASEM.Common.ASEMVersion.Equals(ASEM.Common.ASEMVersion)"]

Return Value

Type: Boolean

[Missing <returns> documentation for "M:ASEM.Common.ASEMVersion.Equals(ASEM.Common.ASEMVersion)"]

Implements

IEquatableTEquals(T)
See Also

Reference

ASEMVersion Class
Equals Overload
ASEM.Common Namespace


ASEMVersion.GetHashCode Method

ASEMVersionGetHashCode Method

[Missing <summary> documentation for "M:ASEM.Common.ASEMVersion.GetHashCode"]

Namespace: ASEM.Common
Assembly: ControlCenterSDK (in ControlCenterSDK.dll) Version: 11.3.30.0 (11.3.030)
Syntax
C#
Copy
public override int GetHashCode()

Return Value

Type: Int32

[Missing <returns> documentation for "M:ASEM.Common.ASEMVersion.GetHashCode"]

See Also

Reference

ASEMVersion Class
ASEM.Common Namespace


ASEMVersion.ToNumber Method

ASEMVersionToNumber Method

[Missing <summary> documentation for "M:ASEM.Common.ASEMVersion.ToNumber"]

Namespace: ASEM.Common
Assembly: ControlCenterSDK (in ControlCenterSDK.dll) Version: 11.3.30.0 (11.3.030)
Syntax
C#
Copy
public long ToNumber()

Return Value

Type: Int64

[Missing <returns> documentation for "M:ASEM.Common.ASEMVersion.ToNumber"]

See Also

Reference

ASEMVersion Class
ASEM.Common Namespace


ASEMVersion.ToString Method

ASEMVersionToString Method

[Missing <summary> documentation for "M:ASEM.Common.ASEMVersion.ToString"]

Namespace: ASEM.Common
Assembly: ControlCenterSDK (in ControlCenterSDK.dll) Version: 11.3.30.0 (11.3.030)
Syntax
C#
Copy
public override string ToString()

Return Value

Type: String

[Missing <returns> documentation for "M:ASEM.Common.ASEMVersion.ToString"]

See Also

Reference

ASEMVersion Class
ASEM.Common Namespace


ClientVersion Class

[Missing <summary> documentation for "T:ASEM.Common.ClientVersion"]

Inheritance Hierarchy
SystemObject
ASEM.CommonClientVersion

Namespace: ASEM.Common
Assembly: ControlCenterSDK (in ControlCenterSDK.dll) Version: 11.3.30.0 (11.3.030)
Syntax
C#
Copy
public class ClientVersion : IEquatable<ClientVersion>

The ClientVersion type exposes the following members.

Constructors
 | Name | Description
Public method | ClientVersion(Int32) | Initializes a new instance of the ClientVersion class
Public method | ClientVersion(ASEMVersion) | Initializes a new instance of the ClientVersion class
Public method | ClientVersion(Int32, Int32, Int32) | Initializes a new instance of the ClientVersion class
Top
Properties
 | Name | Description
Public property | Build |
Public property | Major |
Public property | Minor |
Top
Methods
 | Name | Description
Public method | Equals(Object) | (Overrides ObjectEquals(Object).)
Public method | Equals(ClientVersion) |
Public method | GetHashCode | (Overrides ObjectGetHashCode.)
Public method | ToString | (Overrides ObjectToString.)
Top
See Also

Reference

ASEM.Common Namespace


ClientVersion Constructor

Overload List
 | Name | Description
Public method | ClientVersion(Int32) | Initializes a new instance of the ClientVersion class
Public method | ClientVersion(ASEMVersion) | Initializes a new instance of the ClientVersion class
Public method | ClientVersion(Int32, Int32, Int32) | Initializes a new instance of the ClientVersion class
Top
See Also

Reference

ClientVersion Class
ASEM.Common Namespace


ClientVersion Constructor (Int32)

Initializes a new instance of the ClientVersion class

Namespace: ASEM.Common
Assembly: ControlCenterSDK (in ControlCenterSDK.dll) Version: 11.3.30.0 (11.3.030)
Syntax
C#
Copy
public ClientVersion(
    int version
)

Parameters

version
Type: SystemInt32

[Missing <param name="version"/> documentation for "M:ASEM.Common.ClientVersion.#ctor(System.Int32)"]

See Also

Reference

ClientVersion Class
ClientVersion Overload
ASEM.Common Namespace


ClientVersion Constructor (ASEMVersion)

Initializes a new instance of the ClientVersion class

Namespace: ASEM.Common
Assembly: ControlCenterSDK (in ControlCenterSDK.dll) Version: 11.3.30.0 (11.3.030)
Syntax
C#
Copy
public ClientVersion(
    ASEMVersion version
)

Parameters

version
Type: ASEM.CommonASEMVersion

[Missing <param name="version"/> documentation for "M:ASEM.Common.ClientVersion.#ctor(ASEM.Common.ASEMVersion)"]

See Also

Reference

ClientVersion Class
ClientVersion Overload
ASEM.Common Namespace


ClientVersion Constructor (Int32, Int32, Int32)

Initializes a new instance of the ClientVersion class

Namespace: ASEM.Common
Assembly: ControlCenterSDK (in ControlCenterSDK.dll) Version: 11.3.30.0 (11.3.030)
Syntax
C#
Copy
public ClientVersion(
    int major,
    int minor,
    int build
)

Parameters

major
Type: SystemInt32

[Missing <param name="major"/> documentation for "M:ASEM.Common.ClientVersion.#ctor(System.Int32,System.Int32,System.Int32)"]

minor
Type: SystemInt32

[Missing <param name="minor"/> documentation for "M:ASEM.Common.ClientVersion.#ctor(System.Int32,System.Int32,System.Int32)"]

build
Type: SystemInt32

[Missing <param name="build"/> documentation for "M:ASEM.Common.ClientVersion.#ctor(System.Int32,System.Int32,System.Int32)"]

See Also

Reference

ClientVersion Class
ClientVersion Overload
ASEM.Common Namespace


ClientVersion Properties

The ClientVersion type exposes the following members.

Properties
 | Name | Description
Public property | Build |
Public property | Major |
Public property | Minor |
Top
See Also

Reference

ClientVersion Class
ASEM.Common Namespace


ClientVersion.Build Property

ClientVersionBuild Property

[Missing <summary> documentation for "P:ASEM.Common.ClientVersion.Build"]

Namespace: ASEM.Common
Assembly: ControlCenterSDK (in ControlCenterSDK.dll) Version: 11.3.30.0 (11.3.030)
Syntax
C#
Copy
public int Build { get; set; }

Property Value

Type: Int32
See Also

Reference

ClientVersion Class
ASEM.Common Namespace


ClientVersion.Major Property

ClientVersionMajor Property

[Missing <summary> documentation for "P:ASEM.Common.ClientVersion.Major"]

Namespace: ASEM.Common
Assembly: ControlCenterSDK (in ControlCenterSDK.dll) Version: 11.3.30.0 (11.3.030)
Syntax
C#
Copy
public int Major { get; set; }

Property Value

Type: Int32
See Also

Reference

ClientVersion Class
ASEM.Common Namespace


ClientVersion.Minor Property

ClientVersionMinor Property

[Missing <summary> documentation for "P:ASEM.Common.ClientVersion.Minor"]

Namespace: ASEM.Common
Assembly: ControlCenterSDK (in ControlCenterSDK.dll) Version: 11.3.30.0 (11.3.030)
Syntax
C#
Copy
public int Minor { get; set; }

Property Value

Type: Int32
See Also

Reference

ClientVersion Class
ASEM.Common Namespace


ClientVersion Methods

The ClientVersion type exposes the following members.

Methods
 | Name | Description
Public method | Equals(Object) | (Overrides ObjectEquals(Object).)
Public method | Equals(ClientVersion) |
Public method | GetHashCode | (Overrides ObjectGetHashCode.)
Public method | ToString | (Overrides ObjectToString.)
Top
See Also

Reference

ClientVersion Class
ASEM.Common Namespace


ClientVersion.Equals Method

ClientVersionEquals Method

Overload List
 | Name | Description
Public method | Equals(Object) | (Overrides ObjectEquals(Object).)
Public method | Equals(ClientVersion) |
Top
See Also

Reference

ClientVersion Class
ASEM.Common Namespace


ClientVersion.Equals Method (Object)

ClientVersionEquals Method (Object)

[Missing <summary> documentation for "M:ASEM.Common.ClientVersion.Equals(System.Object)"]

Namespace: ASEM.Common
Assembly: ControlCenterSDK (in ControlCenterSDK.dll) Version: 11.3.30.0 (11.3.030)
Syntax
C#
Copy
public override bool Equals(
    Object obj
)

Parameters

obj
Type: SystemObject

[Missing <param name="obj"/> documentation for "M:ASEM.Common.ClientVersion.Equals(System.Object)"]

Return Value

Type: Boolean

[Missing <returns> documentation for "M:ASEM.Common.ClientVersion.Equals(System.Object)"]

See Also

Reference

ClientVersion Class
Equals Overload
ASEM.Common Namespace


ClientVersion.Equals Method (ClientVersion)

ClientVersionEquals Method (ClientVersion)

[Missing <summary> documentation for "M:ASEM.Common.ClientVersion.Equals(ASEM.Common.ClientVersion)"]

Namespace: ASEM.Common
Assembly: ControlCenterSDK (in ControlCenterSDK.dll) Version: 11.3.30.0 (11.3.030)
Syntax
C#
Copy
public bool Equals(
    ClientVersion other
)

Parameters

other
Type: ASEM.CommonClientVersion

[Missing <param name="other"/> documentation for "M:ASEM.Common.ClientVersion.Equals(ASEM.Common.ClientVersion)"]

Return Value

Type: Boolean

[Missing <returns> documentation for "M:ASEM.Common.ClientVersion.Equals(ASEM.Common.ClientVersion)"]

Implements

IEquatableTEquals(T)
See Also

Reference

ClientVersion Class
Equals Overload
ASEM.Common Namespace


ClientVersion.GetHashCode Method

ClientVersionGetHashCode Method

[Missing <summary> documentation for "M:ASEM.Common.ClientVersion.GetHashCode"]

Namespace: ASEM.Common
Assembly: ControlCenterSDK (in ControlCenterSDK.dll) Version: 11.3.30.0 (11.3.030)
Syntax
C#
Copy
public override int GetHashCode()

Return Value

Type: Int32

[Missing <returns> documentation for "M:ASEM.Common.ClientVersion.GetHashCode"]

See Also

Reference

ClientVersion Class
ASEM.Common Namespace


ClientVersion.ToString Method

ClientVersionToString Method

[Missing <summary> documentation for "M:ASEM.Common.ClientVersion.ToString"]

Namespace: ASEM.Common
Assembly: ControlCenterSDK (in ControlCenterSDK.dll) Version: 11.3.30.0 (11.3.030)
Syntax
C#
Copy
public override string ToString()

Return Value

Type: String

[Missing <returns> documentation for "M:ASEM.Common.ClientVersion.ToString"]

See Also

Reference

ClientVersion Class
ASEM.Common Namespace


ControlCenterSDK Namespace

This namespace contains all the classes of Control Center SDK.
Classes
 | Class | Description
Public class | AddressAndMask | This class allows to store an IP address and a network mask together.
Public class | DataMonitorService | This service provides data monitor access to a device, if it has this functionality.
Public class | Device | This class is a machine in a domain.
Public class | DeviceInfo | Informations about a device.
Public class | Domain | This class manages the connection and the browsing of a domain.
Public class | InvalidLoginException | This exception is thrown when an invalid username and password are provided in a login.
Public class | ManagementService | This service can be used to manage files and processes of a remote device.
Public class | ProcessInfo | The informations of a process executing in a remote device.
Public class | SDKException | Main exception class for SDK.
Public class | SerialPasstroughService | This service provides access to the remote serial passtrough.
 | VPNService | This service can be used to connect the VPN to a device.
Structures
 | Structure | Description
Public structure | ConnectionInfo | Folder informations.
Public structure | DataMonitorServiceLogEntry | This is a descriptor for a certain log.
Public structure | FolderInfo | Folder informations.
Interfaces
 | Interface | Description
Public interface | IService | This interface abstracts connect and disconnect commands to a device's service.
Enumerations
 | Enumeration | Description
Public enumeration | DataMonitorServiceLogType | This is the type of the log.
Public enumeration | EncapsulationType | The encapsulation type
Public enumeration | FileTransferBehavior | This enum specifies the behavior of the file transfer when transferring a file that is already present in destination folder.
Public enumeration | FlowControlType | Specifies the type of control flow of the serial port.
Public enumeration | IPAssignmentMode | Specifies whether an IP Address should be manually set or automatically assigned.


AddressAndMask Class

This class allows to store an IP address and a network mask together.
Inheritance Hierarchy
SystemObject
ControlCenterSDKAddressAndMask

Namespace: ControlCenterSDK
Assembly: ControlCenterSDK (in ControlCenterSDK.dll) Version: 11.3.30.0 (11.3.030)
Syntax
C#
Copy
public class AddressAndMask

The AddressAndMask type exposes the following members.

Constructors
 | Name | Description
Public method | AddressAndMask(IPAddress, IPAddress) | Constructor that takes two IPAddress objects.
Public method | AddressAndMask(String, String) | Constructor that parses two strings.
Top
Methods
 | Name | Description
Public method | Equals | Compares two AddressAndMask objects. (Overrides ObjectEquals(Object).)
Public method | GetHashCode | Returns a hash value for the current instance. (Overrides ObjectGetHashCode.)
Top
Fields
 | Name | Description
Public field | Address | The IP address.
Public field | Mask | The network mask.
Top
See Also

Reference

ControlCenterSDK Namespace


AddressAndMask Constructor

Overload List
 | Name | Description
Public method | AddressAndMask(IPAddress, IPAddress) | Constructor that takes two IPAddress objects.
Public method | AddressAndMask(String, String) | Constructor that parses two strings.
Top
See Also

Reference

AddressAndMask Class


AddressAndMask Constructor (IPAddress, IPAddress)

Constructor that takes two IPAddress objects.

Namespace: ControlCenterSDK
Assembly: ControlCenterSDK (in ControlCenterSDK.dll) Version: 11.3.30.0 (11.3.030)
Syntax
C#
Copy
public AddressAndMask(
    IPAddress addr,
    IPAddress mask
)

Parameters

addr
Type: System.NetIPAddress
the IP address
mask
Type: System.NetIPAddress
the network mask
See Also

Reference

AddressAndMask Class
AddressAndMask Overload


AddressAndMask Constructor (String, String)

Constructor that parses two strings.

Namespace: ControlCenterSDK
Assembly: ControlCenterSDK (in ControlCenterSDK.dll) Version: 11.3.30.0 (11.3.030)
Syntax
C#
Copy
public AddressAndMask(
    string addr,
    string mask
)

Parameters

addr
Type: SystemString
a string representing the IP address
mask
Type: SystemString
a string representing the network mask
See Also

Reference

AddressAndMask Class
AddressAndMask Overload


AddressAndMask Methods

The AddressAndMask type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Compares two AddressAndMask objects. (Overrides ObjectEquals(Object).)
Public method | GetHashCode | Returns a hash value for the current instance. (Overrides ObjectGetHashCode.)
Top
See Also

Reference

AddressAndMask Class


AddressAndMask.Equals Method

AddressAndMaskEquals Method

Compares two AddressAndMask objects.

Namespace: ControlCenterSDK
Assembly: ControlCenterSDK (in ControlCenterSDK.dll) Version: 11.3.30.0 (11.3.030)
Syntax
C#
Copy
public override bool Equals(
    Object comparand
)

Parameters

comparand
Type: SystemObject
An AddressAndMask instance to compare to the current instance.

Return Value

Type: Boolean
true if the two addresses are equal; otherwise, false.
See Also

Reference

AddressAndMask Class


AddressAndMask.GetHashCode Method

AddressAndMaskGetHashCode Method

Returns a hash value for the current instance.

Namespace: ControlCenterSDK
Assembly: ControlCenterSDK (in ControlCenterSDK.dll) Version: 11.3.30.0 (11.3.030)
Syntax
C#
Copy
public override int GetHashCode()

Return Value

Type: Int32
An integer hash value
See Also

Reference

AddressAndMask Class


AddressAndMask Fields

The AddressAndMask type exposes the following members.

Fields
 | Name | Description
Public field | Address | The IP address.
Public field | Mask | The network mask.
Top
See Also

Reference

AddressAndMask Class


AddressAndMask.Address Field

AddressAndMaskAddress Field

The IP address.

Namespace: ControlCenterSDK
Assembly: ControlCenterSDK (in ControlCenterSDK.dll) Version: 11.3.30.0 (11.3.030)
Syntax
C#
Copy
public IPAddress Address

Field Value

Type: IPAddress
See Also

Reference

AddressAndMask Class


AddressAndMask.Mask Field

AddressAndMaskMask Field

The network mask.

Namespace: ControlCenterSDK
Assembly: ControlCenterSDK (in ControlCenterSDK.dll) Version: 11.3.30.0 (11.3.030)
Syntax
C#
Copy
public IPAddress Mask

Field Value

Type: IPAddress
See Also

Reference

AddressAndMask Class


ConnectionInfo Structure

Folder informations.

Namespace: ControlCenterSDK
Assembly: ControlCenterSDK (in ControlCenterSDK.dll) Version: 11.3.30.0 (11.3.030)
Syntax
C#
Copy
public struct ConnectionInfo

The ConnectionInfo type exposes the following members.

Fields
 | Name | Description
Public field | ConnectionID | The identifier of the connection.
Public field | ConnectionTime | The time the connection started.
Public field | DisconnectionTime | The time the connection has been closed.
Public field | HasComment | This property is true when the connection has a comment. If the connection is still open the value will be null.
Public field | RemoteDevice | The remove device name.
Public field | UserName | The user who has connected to the device.
Public field | UserPublicIP | The public IP of the user.
Top
See Also

Reference

ControlCenterSDK Namespace


ConnectionInfo Fields

The ConnectionInfo type exposes the following members.

Fields
 | Name | Description
Public field | ConnectionID | The identifier of the connection.
Public field | ConnectionTime | The time the connection started.
Public field | DisconnectionTime | The time the connection has been closed.
Public field | HasComment | This property is true when the connection has a comment. If the connection is still open the value will be null.
Public field | RemoteDevice | The remove device name.
Public field | UserName | The user who has connected to the device.
Public field | UserPublicIP | The public IP of the user.
Top
See Also

Reference

ConnectionInfo Structure


ConnectionInfo.ConnectionID Field

ConnectionInfoConnectionID Field

The identifier of the connection.

Namespace: ControlCenterSDK
Assembly: ControlCenterSDK (in ControlCenterSDK.dll) Version: 11.3.30.0 (11.3.030)
Syntax
C#
Copy
public int ConnectionID

Field Value

Type: Int32
See Also

Reference

ConnectionInfo Structure


ConnectionInfo.ConnectionTime Field

ConnectionInfoConnectionTime Field

The time the connection started.

Namespace: ControlCenterSDK
Assembly: ControlCenterSDK (in ControlCenterSDK.dll) Version: 11.3.30.0 (11.3.030)
Syntax
C#
Copy
public DateTimeOffset ConnectionTime

Field Value

Type: DateTimeOffset
See Also

Reference

ConnectionInfo Structure


ConnectionInfo.DisconnectionTime Field

ConnectionInfoDisconnectionTime Field

The time the connection has been closed.

Namespace: ControlCenterSDK
Assembly: ControlCenterSDK (in ControlCenterSDK.dll) Version: 11.3.30.0 (11.3.030)
Syntax
C#
Copy
public Nullable<DateTimeOffset> DisconnectionTime

Field Value

Type: Nullable DateTimeOffset
See Also

Reference

ConnectionInfo Structure


ConnectionInfo.HasComment Field

ConnectionInfoHasComment Field

This property is true when the connection has a comment. If the connection is still open the value will be null.

Namespace: ControlCenterSDK
Assembly: ControlCenterSDK (in ControlCenterSDK.dll) Version: 11.3.30.0 (11.3.030)
Syntax
C#
Copy
public bool HasComment

Field Value

Type: Boolean
See Also

Reference

ConnectionInfo Structure


ConnectionInfo.RemoteDevice Field

ConnectionInfoRemoteDevice Field

The remove device name.

Namespace: ControlCenterSDK
Assembly: ControlCenterSDK (in ControlCenterSDK.dll) Version: 11.3.30.0 (11.3.030)
Syntax
C#
Copy
public string RemoteDevice

Field Value

Type: String
See Also

Reference

ConnectionInfo Structure


ConnectionInfo.UserName Field

ConnectionInfoUserName Field

The user who has connected to the device.

Namespace: ControlCenterSDK
Assembly: ControlCenterSDK (in ControlCenterSDK.dll) Version: 11.3.30.0 (11.3.030)
Syntax
C#
Copy
public string UserName

Field Value

Type: String
See Also

Reference

ConnectionInfo Structure


ConnectionInfo.UserPublicIP Field

ConnectionInfoUserPublicIP Field

The public IP of the user.

Namespace: ControlCenterSDK
Assembly: ControlCenterSDK (in ControlCenterSDK.dll) Version: 11.3.30.0 (11.3.030)
Syntax
C#
Copy
public string UserPublicIP

Field Value

Type: String
See Also

Reference

ConnectionInfo Structure


DataMonitorService Class

This service provides data monitor access to a device, if it has this functionality.
Inheritance Hierarchy
SystemObject
ControlCenterSDKDataMonitorService

Namespace: ControlCenterSDK
Assembly: ControlCenterSDK (in ControlCenterSDK.dll) Version: 11.3.30.0 (11.3.030)
Syntax
C#
Copy
public class DataMonitorService : IService

The DataMonitorService type exposes the following members.

Properties
 | Name | Description
Public property | DataLogList | The list of all the data loggers running.
Public property | ExportLogsTimeout | Timeout in milliseconds after which a timeout exception is thrown if the export is not completed in the meantime.
Public property | HistoricalLogList | The list of the historical logs running in the application.
Public property | IsConnected | Test whether the service is connected or not.
Public property | VariablesTraceLogList | The list of variables for which a trace is available.
Top
Methods
 | Name | Description
Public method | Connect | Connect the service. Can be called multiple times safely.
Public method | Disconnect | Disconnect the service. Can be called multiple times safely.
Public method | ExportLogs(String) | Export all the available logs into a local folder.
Public method | ExportLogs(String, ListDataMonitorServiceLogEntry) | Export a list of logs into a local folder.
Public method | RefreshLogList | Reload the list of logs available.
Top
Thread Safety
Instance members of this type are not safe for multi-threaded operations.
See Also

Reference

ControlCenterSDK Namespace


DataMonitorService Properties

The DataMonitorService type exposes the following members.

Properties
 | Name | Description
Public property | DataLogList | The list of all the data loggers running.
Public property | ExportLogsTimeout | Timeout in milliseconds after which a timeout exception is thrown if the export is not completed in the meantime.
Public property | HistoricalLogList | The list of the historical logs running in the application.
Public property | IsConnected | Test whether the service is connected or not.
Public property | VariablesTraceLogList | The list of variables for which a trace is available.
Top
See Also

Reference

DataMonitorService Class


DataMonitorService.DataLogList Property

DataMonitorServiceDataLogList Property

The list of all the data loggers running.

Namespace: ControlCenterSDK
Assembly: ControlCenterSDK (in ControlCenterSDK.dll) Version: 11.3.30.0 (11.3.030)
Syntax
C#
Copy
public List<DataMonitorServiceLogEntry> DataLogList { get; }

Property Value

Type: List DataMonitorServiceLogEntry
See Also

Reference

DataMonitorService Class


DataMonitorService.ExportLogsTimeout Property

DataMonitorServiceExportLogsTimeout Property

Timeout in milliseconds after which a timeout exception is thrown if the export is not completed in the meantime.

Namespace: ControlCenterSDK
Assembly: ControlCenterSDK (in ControlCenterSDK.dll) Version: 11.3.30.0 (11.3.030)
Syntax
C#
Copy
public int ExportLogsTimeout { get; set; }

Property Value

Type: Int32
See Also

Reference

DataMonitorService Class


DataMonitorService.HistoricalLogList Property

DataMonitorServiceHistoricalLogList Property

The list of the historical logs running in the application.

Namespace: ControlCenterSDK
Assembly: ControlCenterSDK (in ControlCenterSDK.dll) Version: 11.3.30.0 (11.3.030)
Syntax
C#
Copy
public List<DataMonitorServiceLogEntry> HistoricalLogList { get; }

Property Value

Type: List DataMonitorServiceLogEntry
See Also

Reference

DataMonitorService Class


DataMonitorService.IsConnected Property

DataMonitorServiceIsConnected Property

Test whether the service is connected or not.

Namespace: ControlCenterSDK
Assembly: ControlCenterSDK (in ControlCenterSDK.dll) Version: 11.3.30.0 (11.3.030)
Syntax
C#
Copy
public bool IsConnected { get; }

Property Value

Type: Boolean

Implements

IServiceIsConnected
See Also

Reference

DataMonitorService Class


DataMonitorService.VariablesTraceLogList Property

DataMonitorServiceVariablesTraceLogList Property

The list of variables for which a trace is available.

Namespace: ControlCenterSDK
Assembly: ControlCenterSDK (in ControlCenterSDK.dll) Version: 11.3.30.0 (11.3.030)
Syntax
C#
Copy
public List<DataMonitorServiceLogEntry> VariablesTraceLogList { get; }

Property Value

Type: List DataMonitorServiceLogEntry
See Also

Reference

DataMonitorService Class


DataMonitorService Methods

The DataMonitorService type exposes the following members.

Methods
 | Name | Description
Public method | Connect | Connect the service. Can be called multiple times safely.
Public method | Disconnect | Disconnect the service. Can be called multiple times safely.
Public method | ExportLogs(String) | Export all the available logs into a local folder.
Public method | ExportLogs(String, ListDataMonitorServiceLogEntry) | Export a list of logs into a local folder.
Public method | RefreshLogList | Reload the list of logs available.
Top
See Also

Reference

DataMonitorService Class


DataMonitorService.Connect Method

DataMonitorServiceConnect Method

Connect the service. Can be called multiple times safely.

Namespace: ControlCenterSDK
Assembly: ControlCenterSDK (in ControlCenterSDK.dll) Version: 11.3.30.0 (11.3.030)
Syntax
C#
Copy
public void Connect()

Implements

IServiceConnect
See Also

Reference

DataMonitorService Class


DataMonitorService.Disconnect Method

DataMonitorServiceDisconnect Method

Disconnect the service. Can be called multiple times safely.

Namespace: ControlCenterSDK
Assembly: ControlCenterSDK (in ControlCenterSDK.dll) Version: 11.3.30.0 (11.3.030)
Syntax
C#
Copy
public void Disconnect()

Implements

IServiceDisconnect
See Also

Reference

DataMonitorService Class


DataMonitorService.ExportLogs Method

DataMonitorServiceExportLogs Method

Overload List
 | Name | Description
Public method | ExportLogs(String) | Export all the available logs into a local folder.
Public method | ExportLogs(String, ListDataMonitorServiceLogEntry) | Export a list of logs into a local folder.
Top
See Also

Reference

DataMonitorService Class


DataMonitorService.ExportLogs Method (String)

DataMonitorServiceExportLogs Method (String)

Export all the available logs into a local folder.

Namespace: ControlCenterSDK
Assembly: ControlCenterSDK (in ControlCenterSDK.dll) Version: 11.3.30.0 (11.3.030)
Syntax
C#
Copy
public void ExportLogs(
    string destinationDir
)

Parameters

destinationDir
Type: SystemString
the local folder in which store the exported logs
See Also

Reference

DataMonitorService Class
ExportLogs Overload


DataMonitorService.ExportLogs Method (String, List(DataMonitorService.LogEntry))

DataMonitorServiceExportLogs Method (String, ListDataMonitorServiceLogEntry)

Export a list of logs into a local folder.

Namespace: ControlCenterSDK
Assembly: ControlCenterSDK (in ControlCenterSDK.dll) Version: 11.3.30.0 (11.3.030)
Syntax
C#
Copy
public void ExportLogs(
    string destinationDir,
    List<DataMonitorServiceLogEntry> logs
)

Parameters

destinationDir
Type: SystemString
the local folder in which store the exported logs
logs
Type: System.Collections.GenericList DataMonitorServiceLogEntry
the list of logs to export
See Also

Reference

DataMonitorService Class
ExportLogs Overload


DataMonitorService.RefreshLogList Method

DataMonitorServiceRefreshLogList Method

Reload the list of logs available.

Namespace: ControlCenterSDK
Assembly: ControlCenterSDK (in ControlCenterSDK.dll) Version: 11.3.30.0 (11.3.030)
Syntax
C#
Copy
public void RefreshLogList()
See Also

Reference

DataMonitorService Class


DataMonitorService.LogEntry Structure

DataMonitorServiceLogEntry Structure

This is a descriptor for a certain log.

Namespace: ControlCenterSDK
Assembly: ControlCenterSDK (in ControlCenterSDK.dll) Version: 11.3.30.0 (11.3.030)
Syntax
C#
Copy
public struct LogEntry

The DataMonitorServiceLogEntry type exposes the following members.

Fields
 | Name | Description
Public field | LastModified | Date time of the last modification.
Public field | Name | The name of the log.
Public field | Type | The type of the log.
Top
See Also

Reference

ControlCenterSDK Namespace


LogEntry Fields

The DataMonitorServiceLogEntry type exposes the following members.

Fields
 | Name | Description
Public field | LastModified | Date time of the last modification.
Public field | Name | The name of the log.
Public field | Type | The type of the log.
Top
See Also

Reference

DataMonitorServiceLogEntry Structure


DataMonitorService.LogEntry.LastModified Field

DataMonitorServiceLogEntryLastModified Field

Date time of the last modification.

Namespace: ControlCenterSDK
Assembly: ControlCenterSDK (in ControlCenterSDK.dll) Version: 11.3.30.0 (11.3.030)
Syntax
C#
Copy
public string LastModified

Field Value

Type: String
See Also

Reference

DataMonitorServiceLogEntry Structure


DataMonitorService.LogEntry.Name Field

DataMonitorServiceLogEntryName Field

The name of the log.

Namespace: ControlCenterSDK
Assembly: ControlCenterSDK (in ControlCenterSDK.dll) Version: 11.3.30.0 (11.3.030)
Syntax
C#
Copy
public string Name

Field Value

Type: String
See Also

Reference

DataMonitorServiceLogEntry Structure


DataMonitorService.LogEntry.Type Field

DataMonitorServiceLogEntryType Field

The type of the log.

Namespace: ControlCenterSDK
Assembly: ControlCenterSDK (in ControlCenterSDK.dll) Version: 11.3.30.0 (11.3.030)
Syntax
C#
Copy
public DataMonitorServiceLogType Type

Field Value

Type: DataMonitorServiceLogType
See Also

Reference

DataMonitorServiceLogEntry Structure


DataMonitorService.LogType Enumeration

DataMonitorServiceLogType Enumeration

This is the type of the log.

Namespace: ControlCenterSDK
Assembly: ControlCenterSDK (in ControlCenterSDK.dll) Version: 11.3.30.0 (11.3.030)
Syntax
C#
Copy
public enum LogType
Members
Member name | Value | Description
Data | 0 | A datalogger.
Historical | 1 | An historical log.
VariableTrace | 2 | The trace of a variable.
See Also

Reference

ControlCenterSDK Namespace


Device Class

This class is a machine in a domain.
Inheritance Hierarchy
SystemObject
ControlCenterSDKDevice

Namespace: ControlCenterSDK
Assembly: ControlCenterSDK (in ControlCenterSDK.dll) Version: 11.3.30.0 (11.3.030)
Syntax
C#
Copy
public sealed class Device : IDisposable

The Device type exposes the following members.

Properties
 | Name | Description
Public property | DataMonitor | Provides access to the DataMonitorService for the device, if available.
Public property | Info | Provides access to the device informations.
Public property | Management | Provides access to the ManagementService for the device.
Public property | SerialPasstrough | Provides access to the SerialPasstroughService for the device.
Public property | VPN | Provides access to the VPNService for the device.
Top
Methods
 | Name | Description
Public method | Dispose | Disconnect all the services
Top
Thread Safety
Instance members of this type are not safe for multi-threaded operations.
See Also

Reference

ControlCenterSDK Namespace


Device Properties

The Device type exposes the following members.

Properties
 | Name | Description
Public property | DataMonitor | Provides access to the DataMonitorService for the device, if available.
Public property | Info | Provides access to the device informations.
Public property | Management | Provides access to the ManagementService for the device.
Public property | SerialPasstrough | Provides access to the SerialPasstroughService for the device.
Public property | VPN | Provides access to the VPNService for the device.
Top
See Also

Reference

Device Class


Device.DataMonitor Property

DeviceDataMonitor Property

Provides access to the DataMonitorService for the device, if available.

Namespace: ControlCenterSDK
Assembly: ControlCenterSDK (in ControlCenterSDK.dll) Version: 11.3.30.0 (11.3.030)
Syntax
C#
Copy
public DataMonitorService DataMonitor { get; }

Property Value

Type: DataMonitorService
See Also

Reference

Device Class


Device.Info Property

DeviceInfo Property

Provides access to the device informations.

Namespace: ControlCenterSDK
Assembly: ControlCenterSDK (in ControlCenterSDK.dll) Version: 11.3.30.0 (11.3.030)
Syntax
C#
Copy
public DeviceInfo Info { get; }

Property Value

Type: DeviceInfo
See Also

Reference

Device Class


Device.Management Property

DeviceManagement Property

Provides access to the ManagementService for the device.

Namespace: ControlCenterSDK
Assembly: ControlCenterSDK (in ControlCenterSDK.dll) Version: 11.3.30.0 (11.3.030)
Syntax
C#
Copy
public ManagementService Management { get; }

Property Value

Type: ManagementService
See Also

Reference

Device Class


Device.SerialPasstrough Property

DeviceSerialPasstrough Property

Provides access to the SerialPasstroughService for the device.

Namespace: ControlCenterSDK
Assembly: ControlCenterSDK (in ControlCenterSDK.dll) Version: 11.3.30.0 (11.3.030)
Syntax
C#
Copy
public SerialPasstroughService SerialPasstrough { get; }

Property Value

Type: SerialPasstroughService
See Also

Reference

Device Class


Device.VPN Property

DeviceVPN Property

Provides access to the VPNService for the device.

Namespace: ControlCenterSDK
Assembly: ControlCenterSDK (in ControlCenterSDK.dll) Version: 11.3.30.0 (11.3.030)
Syntax
C#
Copy
public VPNService VPN { get; }

Property Value

Type: VPNService
See Also

Reference

Device Class


Device Methods

The Device type exposes the following members.

Methods
 | Name | Description
Public method | Dispose | Disconnect all the services
Top
See Also

Reference

Device Class


Device.Dispose Method

DeviceDispose Method

Disconnect all the services

Namespace: ControlCenterSDK
Assembly: ControlCenterSDK (in ControlCenterSDK.dll) Version: 11.3.30.0 (11.3.030)
Syntax
C#
Copy
public void Dispose()

Implements

IDisposableDispose
See Also

Reference

Device Class


DeviceInfo Class

Informations about a device.
Inheritance Hierarchy
SystemObject
ControlCenterSDKDeviceInfo

Namespace: ControlCenterSDK
Assembly: ControlCenterSDK (in ControlCenterSDK.dll) Version: 11.3.30.0 (11.3.030)
Syntax
C#
Copy
public class DeviceInfo

The DeviceInfo type exposes the following members.

Properties
 | Name | Description
Public property | ClientVersion | The runtime version that is currently running on the device.
Public property | ClientVersionInt | The runtime version in the format (major * 100 + minor) * 10000 + build.
Public property | Guid | The identifier of the device.
Public property | IsOnline | Test whether the device is online.
Public property | IsRouter | This property is true when the device is a Router.
Public property | LastLoginTime | The last time the device has been authenticated by the server.
Public property | MACAddress | The MAC address of the network card.
Public property | Name | The name of the device.
Public property | OsVersion | The operating system version.
Public property | PublicIPAddress | The IP reachable from the public network.
Public property | ReachableIPAddresses | The list of IP addresses with their relative network masks, that can be reachable once the VPN is connected.
Public property | UnreachableIPAddresses | The list of IP addresses with their relative network masks, that are not reachable through the VPN service.
Top
Thread Safety
Instance members of this type are safe for multi-threaded operations.
See Also

Reference

ControlCenterSDK Namespace


DeviceInfo Properties

The DeviceInfo type exposes the following members.

Properties
 | Name | Description
Public property | ClientVersion | The runtime version that is currently running on the device.
Public property | ClientVersionInt | The runtime version in the format (major * 100 + minor) * 10000 + build.
Public property | Guid | The identifier of the device.
Public property | IsOnline | Test whether the device is online.
Public property | IsRouter | This property is true when the device is a Router.
Public property | LastLoginTime | The last time the device has been authenticated by the server.
Public property | MACAddress | The MAC address of the network card.
Public property | Name | The name of the device.
Public property | OsVersion | The operating system version.
Public property | PublicIPAddress | The IP reachable from the public network.
Public property | ReachableIPAddresses | The list of IP addresses with their relative network masks, that can be reachable once the VPN is connected.
Public property | UnreachableIPAddresses | The list of IP addresses with their relative network masks, that are not reachable through the VPN service.
Top
See Also

Reference

DeviceInfo Class


DeviceInfo.ClientVersion Property

DeviceInfoClientVersion Property

The runtime version that is currently running on the device.

Namespace: ControlCenterSDK
Assembly: ControlCenterSDK (in ControlCenterSDK.dll) Version: 11.3.30.0 (11.3.030)
Syntax
C#
Copy
public string ClientVersion { get; }

Property Value

Type: String
See Also

Reference

DeviceInfo Class


DeviceInfo.ClientVersionInt Property

DeviceInfoClientVersionInt Property

The runtime version in the format (major * 100 + minor) * 10000 + build.

Namespace: ControlCenterSDK
Assembly: ControlCenterSDK (in ControlCenterSDK.dll) Version: 11.3.30.0 (11.3.030)
Syntax
C#
Copy
public uint ClientVersionInt { get; }

Property Value

Type: UInt32
See Also

Reference

DeviceInfo Class


DeviceInfo.Guid Property

DeviceInfoGuid Property

The identifier of the device.

Namespace: ControlCenterSDK
Assembly: ControlCenterSDK (in ControlCenterSDK.dll) Version: 11.3.30.0 (11.3.030)
Syntax
C#
Copy
public byte[] Guid { get; }

Property Value

Type: Byte
See Also

Reference

DeviceInfo Class


DeviceInfo.IsOnline Property

DeviceInfoIsOnline Property

Test whether the device is online.

Namespace: ControlCenterSDK
Assembly: ControlCenterSDK (in ControlCenterSDK.dll) Version: 11.3.30.0 (11.3.030)
Syntax
C#
Copy
public bool IsOnline { get; }

Property Value

Type: Boolean
See Also

Reference

DeviceInfo Class


DeviceInfo.IsRouter Property

DeviceInfoIsRouter Property

This property is true when the device is a Router.

Namespace: ControlCenterSDK
Assembly: ControlCenterSDK (in ControlCenterSDK.dll) Version: 11.3.30.0 (11.3.030)
Syntax
C#
Copy
public bool IsRouter { get; }

Property Value

Type: Boolean
See Also

Reference

DeviceInfo Class


DeviceInfo.LastLoginTime Property

DeviceInfoLastLoginTime Property

The last time the device has been authenticated by the server.

Namespace: ControlCenterSDK
Assembly: ControlCenterSDK (in ControlCenterSDK.dll) Version: 11.3.30.0 (11.3.030)
Syntax
C#
Copy
public DateTimeOffset LastLoginTime { get; }

Property Value

Type: DateTimeOffset
See Also

Reference

DeviceInfo Class


DeviceInfo.MACAddress Property

DeviceInfoMACAddress Property

The MAC address of the network card.

Namespace: ControlCenterSDK
Assembly: ControlCenterSDK (in ControlCenterSDK.dll) Version: 11.3.30.0 (11.3.030)
Syntax
C#
Copy
public byte[] MACAddress { get; }

Property Value

Type: Byte
See Also

Reference

DeviceInfo Class


DeviceInfo.Name Property

DeviceInfoName Property

The name of the device.

Namespace: ControlCenterSDK
Assembly: ControlCenterSDK (in ControlCenterSDK.dll) Version: 11.3.30.0 (11.3.030)
Syntax
C#
Copy
public string Name { get; }

Property Value

Type: String
See Also

Reference

DeviceInfo Class


DeviceInfo.OsVersion Property

DeviceInfoOsVersion Property

The operating system version.

Namespace: ControlCenterSDK
Assembly: ControlCenterSDK (in ControlCenterSDK.dll) Version: 11.3.30.0 (11.3.030)
Syntax
C#
Copy
public OperatingSystem OsVersion { get; }

Property Value

Type: OperatingSystem
See Also

Reference

DeviceInfo Class


DeviceInfo.PublicIPAddress Property

DeviceInfoPublicIPAddress Property

The IP reachable from the public network.

Namespace: ControlCenterSDK
Assembly: ControlCenterSDK (in ControlCenterSDK.dll) Version: 11.3.30.0 (11.3.030)
Syntax
C#
Copy
public IPAddress PublicIPAddress { get; }

Property Value

Type: IPAddress
See Also

Reference

DeviceInfo Class


DeviceInfo.ReachableIPAddresses Property

DeviceInfoReachableIPAddresses Property

The list of IP addresses with their relative network masks, that can be reachable once the VPN is connected.

Namespace: ControlCenterSDK
Assembly: ControlCenterSDK (in ControlCenterSDK.dll) Version: 11.3.30.0 (11.3.030)
Syntax
C#
Copy
public List<AddressAndMask> ReachableIPAddresses { get; }

Property Value

Type: List AddressAndMask
Remarks
This list may be updated when you connect the VPN, by using Connect of VPNService. The addresses listed by this property, before that call, may be outdated.
See Also

Reference

DeviceInfo Class


DeviceInfo.UnreachableIPAddresses Property

DeviceInfoUnreachableIPAddresses Property

The list of IP addresses with their relative network masks, that are not reachable through the VPN service.

Namespace: ControlCenterSDK
Assembly: ControlCenterSDK (in ControlCenterSDK.dll) Version: 11.3.30.0 (11.3.030)
Syntax
C#
Copy
public List<AddressAndMask> UnreachableIPAddresses { get; }

Property Value

Type: List AddressAndMask
See Also

Reference

DeviceInfo Class


Domain Class

This class manages the connection and the browsing of a domain.
Inheritance Hierarchy
SystemObject
ControlCenterSDKDomain

Namespace: ControlCenterSDK
Assembly: ControlCenterSDK (in ControlCenterSDK.dll) Version: 11.3.30.0 (11.3.030)
Syntax
C#
Copy
public sealed class Domain : IDisposable

The Domain type exposes the following members.

Constructors
 | Name | Description
Public method | Domain | Initialize the domain with the name and the connection settings taken from the current Control Center configuration.
Top
Properties
 | Name | Description
Public property | IsConnected | This property is true when you are connected to the domain.
Top
Methods
 | Name | Description
Public method | Connect | Connect the domain with user and password
Public method | ConnectDevice | Authenticate and connect to the given device.
Public method | Disconnect | Disconnect the user from the domain. Be aware that when disconnected, also devices connections are disconnected.
Public method | Dispose | Disconnect the user from the domain and dispose this object.
Public method | GetConnectionComment | Get the comment of a connection.
Public method | GetConnectionsAudit | Get the connections audit list.
 | GetDevice | Get a device by its full path in the domain.
Public method | GetDevices | Get the list of all the devices in the domain.
Public method | GetDevices(String, Boolean) | Get the list of devices inside a folder. This function does not returns devices in the sub-folders.
Public method | GetDevices(FolderInfo, Boolean) | Get the list of devices inside a folder. This function does not returns devices in the sub-folders.
Public method | GetFolders(String) | Get the list of the subfolders of a given folder path.
Public method | GetFolders(FolderInfo) | Get the list of the sub-folders of a given folder.
Top
Thread Safety
Instance members of this type are not safe for multi-threaded operations.
See Also

Reference

ControlCenterSDK Namespace


Domain Constructor

Initialize the domain with the name and the connection settings taken from the current Control Center configuration.

Namespace: ControlCenterSDK
Assembly: ControlCenterSDK (in ControlCenterSDK.dll) Version: 11.3.30.0 (11.3.030)
Syntax
C#
Copy
public Domain(
    string name
)

Parameters

name
Type: SystemString
the domain name
See Also

Reference

Domain Class


Domain Properties

The Domain type exposes the following members.

Properties
 | Name | Description
Public property | IsConnected | This property is true when you are connected to the domain.
Top
See Also

Reference

Domain Class


Domain.IsConnected Property

DomainIsConnected Property

This property is true when you are connected to the domain.

Namespace: ControlCenterSDK
Assembly: ControlCenterSDK (in ControlCenterSDK.dll) Version: 11.3.30.0 (11.3.030)
Syntax
C#
Copy
public bool IsConnected { get; }

Property Value

Type: Boolean
See Also

Reference

Domain Class


Domain Methods

The Domain type exposes the following members.

Methods
 | Name | Description
Public method | Connect | Connect the domain with user and password
Public method | ConnectDevice | Authenticate and connect to the given device.
Public method | Disconnect | Disconnect the user from the domain. Be aware that when disconnected, also devices connections are disconnected.
Public method | Dispose | Disconnect the user from the domain and dispose this object.
Public method | GetConnectionComment | Get the comment of a connection.
Public method | GetConnectionsAudit | Get the connections audit list.
 | GetDevice | Get a device by its full path in the domain.
Public method | GetDevices | Get the list of all the devices in the domain.
Public method | GetDevices(String, Boolean) | Get the list of devices inside a folder. This function does not returns devices in the sub-folders.
Public method | GetDevices(FolderInfo, Boolean) | Get the list of devices inside a folder. This function does not returns devices in the sub-folders.
Public method | GetFolders(String) | Get the list of the subfolders of a given folder path.
Public method | GetFolders(FolderInfo) | Get the list of the sub-folders of a given folder.
Top
See Also

Reference

Domain Class


Domain.Connect Method

DomainConnect Method

Connect the domain with user and password

Namespace: ControlCenterSDK
Assembly: ControlCenterSDK (in ControlCenterSDK.dll) Version: 11.3.30.0 (11.3.030)
Syntax
C#
Copy
public void Connect(
    string user,
    string passwd
)

Parameters

user
Type: SystemString
the username
passwd
Type: SystemString
the password
See Also

Reference

Domain Class


Domain.ConnectDevice Method

DomainConnectDevice Method

Authenticate and connect to the given device.

Namespace: ControlCenterSDK
Assembly: ControlCenterSDK (in ControlCenterSDK.dll) Version: 11.3.30.0 (11.3.030)
Syntax
C#
Copy
public Device ConnectDevice(
    DeviceInfo device
)

Parameters

device
Type: ControlCenterSDKDeviceInfo
the device to be connected

Return Value

Type: Device
A connected device.
See Also

Reference

Domain Class


Domain.Disconnect Method

DomainDisconnect Method

Disconnect the user from the domain. Be aware that when disconnected, also devices connections are disconnected.

Namespace: ControlCenterSDK
Assembly: ControlCenterSDK (in ControlCenterSDK.dll) Version: 11.3.30.0 (11.3.030)
Syntax
C#
Copy
public void Disconnect()
See Also

Reference

Domain Class


Domain.Dispose Method

DomainDispose Method

Disconnect the user from the domain and dispose this object.

Namespace: ControlCenterSDK
Assembly: ControlCenterSDK (in ControlCenterSDK.dll) Version: 11.3.30.0 (11.3.030)
Syntax
C#
Copy
public void Dispose()

Implements

IDisposableDispose
See Also

Reference

Domain Class


Domain.GetConnectionComment Method

DomainGetConnectionComment Method

Get the comment of a connection.

Namespace: ControlCenterSDK
Assembly: ControlCenterSDK (in ControlCenterSDK.dll) Version: 11.3.30.0 (11.3.030)
Syntax
C#
Copy
public string GetConnectionComment(
    int connectionID
)

Parameters

connectionID
Type: SystemInt32
the identifier of the connection

Return Value

Type: String
The comment of the connection.
See Also

Reference

Domain Class


Domain.GetConnectionsAudit Method

DomainGetConnectionsAudit Method

Get the connections audit list.

Namespace: ControlCenterSDK
Assembly: ControlCenterSDK (in ControlCenterSDK.dll) Version: 11.3.30.0 (11.3.030)
Syntax
C#
Copy
public List<ConnectionInfo> GetConnectionsAudit(
    DateTime dateFrom,
    DateTime dateTo,
    string userFilter = "",
    string deviceFilter = ""
)

Parameters

dateFrom
Type: SystemDateTime
the lower bound date
dateTo
Type: SystemDateTime
the upper bound date
userFilter (Optional)
Type: SystemString
optional filter by user name
deviceFilter (Optional)
Type: SystemString
optional filter by device name

Return Value

Type: List ConnectionInfo
A list with the detail of each connection.
See Also

Reference

Domain Class


Domain.GetDevice Method

DomainGetDevice Method

Get a device by its full path in the domain.

Namespace: ControlCenterSDK
Assembly: ControlCenterSDK (in ControlCenterSDK.dll) Version: 11.3.30.0 (11.3.030)
Syntax
C#
Copy
public DeviceInfo GetDevice(
    string path
)

Parameters

path
Type: SystemString
the path of the device in the domain

Return Value

Type: DeviceInfo
the given device if present
Examples
Get the device named "Machine1" in folder "Italy"
C#
Copy
Domain domain = new Domain("MyDomain");
domain.Connect("admin", "password");
DeviceInfo dev = domain.GetDevice(@"Italy\Machine1");
System.Diagnostics.Debug.Assert(dev.Name == "Machine1");
domain.Dispose();
See Also

Reference

Domain Class


Domain.GetDevices Method

DomainGetDevices Method

Overload List
 | Name | Description
Public method | GetDevices | Get the list of all the devices in the domain.
Public method | GetDevices(String, Boolean) | Get the list of devices inside a folder. This function does not returns devices in the sub-folders.
Public method | GetDevices(FolderInfo, Boolean) | Get the list of devices inside a folder. This function does not returns devices in the sub-folders.
Top
See Also

Reference

Domain Class


Domain.GetDevices Method

DomainGetDevices Method

Get the list of all the devices in the domain.

Namespace: ControlCenterSDK
Assembly: ControlCenterSDK (in ControlCenterSDK.dll) Version: 11.3.30.0 (11.3.030)
Syntax
C#
Copy
public List<DeviceInfo> GetDevices()

Return Value

Type: List DeviceInfo
a list of devices
See Also

Reference

Domain Class
GetDevices Overload


Domain.GetDevices Method (String, Boolean)

DomainGetDevices Method (String, Boolean)

Get the list of devices inside a folder. This function does not returns devices in the sub-folders.

Namespace: ControlCenterSDK
Assembly: ControlCenterSDK (in ControlCenterSDK.dll) Version: 11.3.30.0 (11.3.030)
Syntax
C#
Copy
public List<DeviceInfo> GetDevices(
    string path,
    bool recursive = false
)

Parameters

path
Type: SystemString
the full path of the folder with the desired devices
recursive (Optional)
Type: SystemBoolean
whether or not to look for devices in subdirectories

Return Value

Type: List DeviceInfo
a list of devices
See Also

Reference

Domain Class
GetDevices Overload


Domain.GetDevices Method (FolderInfo, Boolean)

DomainGetDevices Method (FolderInfo, Boolean)

Get the list of devices inside a folder. This function does not returns devices in the sub-folders.

Namespace: ControlCenterSDK
Assembly: ControlCenterSDK (in ControlCenterSDK.dll) Version: 11.3.30.0 (11.3.030)
Syntax
C#
Copy
public List<DeviceInfo> GetDevices(
    FolderInfo path,
    bool recursive = false
)

Parameters

path
Type: ControlCenterSDKFolderInfo
the folder with the desired devices
recursive (Optional)
Type: SystemBoolean
whether or not to look for devices in subdirectories

Return Value

Type: List DeviceInfo
a list of devices
See Also

Reference

Domain Class
GetDevices Overload


Domain.GetFolders Method

DomainGetFolders Method

Overload List
 | Name | Description
Public method | GetFolders(String) | Get the list of the subfolders of a given folder path.
Public method | GetFolders(FolderInfo) | Get the list of the sub-folders of a given folder.
Top
See Also

Reference

Domain Class


Domain.GetFolders Method (String)

DomainGetFolders Method (String)

Get the list of the subfolders of a given folder path.

Namespace: ControlCenterSDK
Assembly: ControlCenterSDK (in ControlCenterSDK.dll) Version: 11.3.30.0 (11.3.030)
Syntax
C#
Copy
public List<FolderInfo> GetFolders(
    string path = ""
)

Parameters

path (Optional)
Type: SystemString
the full path of the parent folder. If not given, the root folder is assumed.

Return Value

Type: List FolderInfo
a list of subfolders
See Also

Reference

Domain Class
GetFolders Overload


Domain.GetFolders Method (FolderInfo)

DomainGetFolders Method (FolderInfo)

Get the list of the sub-folders of a given folder.

Namespace: ControlCenterSDK
Assembly: ControlCenterSDK (in ControlCenterSDK.dll) Version: 11.3.30.0 (11.3.030)
Syntax
C#
Copy
public List<FolderInfo> GetFolders(
    FolderInfo path
)

Parameters

path
Type: ControlCenterSDKFolderInfo
the parent folder

Return Value

Type: List FolderInfo
a list of subfolders
See Also

Reference

Domain Class
GetFolders Overload


EncapsulationType Enumeration

The encapsulation type

Namespace: ControlCenterSDK
Assembly: ControlCenterSDK (in ControlCenterSDK.dll) Version: 11.3.30.0 (11.3.030)
Syntax
C#
Copy
public enum EncapsulationType
Members
Member name | Value | Description
DataOnly | 0 | Remote only raw data.
DataPortConfigurationControlSignals | 1 | Remote raw data, port configuration and control signals.
DataPortConfiguration | 2 | Remote raw data and port configuration.
See Also

Reference

ControlCenterSDK Namespace


FileTransferBehavior Enumeration

This enum specifies the behavior of the file transfer when transferring a file that is already present in destination folder.

Namespace: ControlCenterSDK
Assembly: ControlCenterSDK (in ControlCenterSDK.dll) Version: 11.3.30.0 (11.3.030)
Syntax
C#
Copy
public enum FileTransferBehavior
Members
Member name | Value | Description
Abort | 0 | Abort the transfer.
Overwrite | 1 | Overwrite the file.
Skip | 2 | Skip the file.
Resume | 3 | Complete the transfer by resuming a previous transfer, if it has not been completed.
See Also

Reference

ControlCenterSDK Namespace


FlowControlType Enumeration

Specifies the type of control flow of the serial port.

Namespace: ControlCenterSDK
Assembly: ControlCenterSDK (in ControlCenterSDK.dll) Version: 11.3.30.0 (11.3.030)
Syntax
C#
Copy
public enum FlowControlType
Members
Member name | Value | Description
None | 0 | No control flow.
XonXoff | 1 | XON/XOFF control flow.
Hardware | 2 | Hardware (RTS/CTR - DTR/DSR) control flow.
See Also

Reference

ControlCenterSDK Namespace


FolderInfo Structure

Folder informations.

Namespace: ControlCenterSDK
Assembly: ControlCenterSDK (in ControlCenterSDK.dll) Version: 11.3.30.0 (11.3.030)
Syntax
C#
Copy
public struct FolderInfo

The FolderInfo type exposes the following members.

Fields
 | Name | Description
Public field | Name | The name of the folder.
Top
See Also

Reference

ControlCenterSDK Namespace


FolderInfo Fields

The FolderInfo type exposes the following members.

Fields
 | Name | Description
Public field | Name | The name of the folder.
Top
See Also

Reference

FolderInfo Structure


FolderInfo.Name Field

FolderInfoName Field

The name of the folder.

Namespace: ControlCenterSDK
Assembly: ControlCenterSDK (in ControlCenterSDK.dll) Version: 11.3.30.0 (11.3.030)
Syntax
C#
Copy
public string Name

Field Value

Type: String
See Also

Reference

FolderInfo Structure


InvalidLoginException Class

This exception is thrown when an invalid username and password are provided in a login.
Inheritance Hierarchy
SystemObject
SystemException
ControlCenterSDKSDKException
ControlCenterSDKInvalidLoginException

Namespace: ControlCenterSDK
Assembly: ControlCenterSDK (in ControlCenterSDK.dll) Version: 11.3.30.0 (11.3.030)
Syntax
C#
Copy
public class InvalidLoginException : SDKException
Constructors
 | Name | Description
Public method | InvalidLoginException | Initializes a new instance of the exception class.
Public method | InvalidLoginException(String) | Initializes a new instance of the exception class with a specified error message.
Public method | InvalidLoginException(String, Exception) | Initializes a new instance of the exception class with a specified error message and a reference to the inner exception that is the cause of this exception.
Top
See Also

Reference

ControlCenterSDK Namespace


InvalidLoginException Constructor

Overload List
 | Name | Description
Public method | InvalidLoginException | Initializes a new instance of the exception class.
Public method | InvalidLoginException(String) | Initializes a new instance of the exception class with a specified error message.
Public method | InvalidLoginException(String, Exception) | Initializes a new instance of the exception class with a specified error message and a reference to the inner exception that is the cause of this exception.
Top
See Also

Reference

InvalidLoginException Class


InvalidLoginException Constructor

Initializes a new instance of the exception class.

Namespace: ControlCenterSDK
Assembly: ControlCenterSDK (in ControlCenterSDK.dll) Version: 11.3.30.0 (11.3.030)
Syntax
C#
Copy
public InvalidLoginException()
See Also

Reference

InvalidLoginException Class
InvalidLoginException Overload


InvalidLoginException Constructor (String)

Initializes a new instance of the exception class with a specified error message.

Namespace: ControlCenterSDK
Assembly: ControlCenterSDK (in ControlCenterSDK.dll) Version: 11.3.30.0 (11.3.030)
Syntax
C#
Copy
public InvalidLoginException(
    string message
)

Parameters

message
Type: SystemString
The message that describes the error.
See Also

Reference

InvalidLoginException Class
InvalidLoginException Overload


InvalidLoginException Constructor (String, Exception)

Initializes a new instance of the exception class with a specified error message and a reference to the inner exception that is the cause of this exception.

Namespace: ControlCenterSDK
Assembly: ControlCenterSDK (in ControlCenterSDK.dll) Version: 11.3.30.0 (11.3.030)
Syntax
C#
Copy
public InvalidLoginException(
    string message,
    Exception innerException
)

Parameters

message
Type: SystemString
The error message that explains the reason for the exception.
innerException
Type: SystemException
The exception that is the cause of the current exception, or a null reference if no inner exception is specified.
See Also

Reference

InvalidLoginException Class
InvalidLoginException Overload


IPAssignmentMode Enumeration

Specifies whether an IP Address should be manually set or automatically assigned.

Namespace: ControlCenterSDK
Assembly: ControlCenterSDK (in ControlCenterSDK.dll) Version: 11.3.30.0 (11.3.030)
Syntax
C#
Copy
public enum IPAssignmentMode
Members
Member name | Value | Description
Automatic | 0 | The IP Address is automatically assigned.
Manual | 1 | The IP Address is manually assigned and specified by the user.
See Also

Reference

ControlCenterSDK Namespace


IService Interface

This interface abstracts connect and disconnect commands to a device's service.

Namespace: ControlCenterSDK
Assembly: ControlCenterSDK (in ControlCenterSDK.dll) Version: 11.3.30.0 (11.3.030)
Syntax
C#
Copy
public interface IService

The IService type exposes the following members.

Properties
 | Name | Description
Public property | IsConnected | Test whether the service is connected or not.
Top
Methods
 | Name | Description
Public method | Connect | Connect the service. Can be called multiple times safely.
Public method | Disconnect | Disconnect the service. Can be called multiple times safely.
Top
See Also

Reference

ControlCenterSDK Namespace


IService Properties

The IService type exposes the following members.

Properties
 | Name | Description
Public property | IsConnected | Test whether the service is connected or not.
Top
See Also

Reference

IService Interface


IService.IsConnected Property

IServiceIsConnected Property

Test whether the service is connected or not.

Namespace: ControlCenterSDK
Assembly: ControlCenterSDK (in ControlCenterSDK.dll) Version: 11.3.30.0 (11.3.030)
Syntax
C#
Copy
bool IsConnected { get; }

Property Value

Type: Boolean
See Also

Reference

IService Interface


IService Methods

The IService type exposes the following members.

Methods
 | Name | Description
Public method | Connect | Connect the service. Can be called multiple times safely.
Public method | Disconnect | Disconnect the service. Can be called multiple times safely.
Top
See Also

Reference

IService Interface


IService.Connect Method

IServiceConnect Method

Connect the service. Can be called multiple times safely.

Namespace: ControlCenterSDK
Assembly: ControlCenterSDK (in ControlCenterSDK.dll) Version: 11.3.30.0 (11.3.030)
Syntax
C#
Copy
void Connect()
See Also

Reference

IService Interface


IService.Disconnect Method

IServiceDisconnect Method

Disconnect the service. Can be called multiple times safely.

Namespace: ControlCenterSDK
Assembly: ControlCenterSDK (in ControlCenterSDK.dll) Version: 11.3.30.0 (11.3.030)
Syntax
C#
Copy
void Disconnect()
See Also

Reference

IService Interface


ManagementService Class

This service can be used to manage files and processes of a remote device.
Inheritance Hierarchy
SystemObject
ControlCenterSDKManagementService

Namespace: ControlCenterSDK
Assembly: ControlCenterSDK (in ControlCenterSDK.dll) Version: 11.3.30.0 (11.3.030)
Syntax
C#
Copy
public class ManagementService : IService

The ManagementService type exposes the following members.

Properties
 | Name | Description
Public property | DefaultExistingFileBehavior | This property specifies the behavior of the file transfer when transferring a file that is already present in destination folder.
Public property | FileTransferTimeout | This is the maximum time in milliseconds that the file transfer can wait the completion.
Public property | IsConnected | Test whether the service is connected or not.
Public property | IsDisconnected |
Public property | IsWaitingAuthorization |
Top
Methods
 | Name | Description
Public method | AddDeviceSessionComment | Set the connection comment.
Public method | Connect | Connect the service. Can be called multiple times safely.
Public method | CreateFolder | Create a folder in the remote file system.
Public method | Delete | Delete a remote file or folder.
Public method | Disconnect | Disconnect the service. Can be called multiple times safely.
Public method | Download | Download a list of files or folders from a remote folder to a local one.
Public method | DownloadDirectoryContent | Download all the files and folders located in a remote folder to a local one.
Public method | ExecuteRemoteProcess | Execute a process.
Public method | GetAvailableDiskMB | Obtains the available disk space on the device
Public method | GetProcessList | Get the list of processes that are currently executing in the device.
Public method | GetSystemTemporaryDirectory | Tries to get the system temporary directory of the remote device
Public method | KillProcess(String) | Kill a process executing in the device.
Public method | KillProcess(ProcessInfo) | Kill a process executing in the device.
Public method | OnConnectionRefused |
Public method | Reboot | Reboot the device.
Public method | Rename | Rename a file or folder.
Public method | Upload | Upload a list of files or folders from a local folder to a remote one.
Top
Thread Safety
Instance members of this type are not safe for multi-threaded operations.
See Also

Reference

ControlCenterSDK Namespace


ManagementService Properties

The ManagementService type exposes the following members.

Properties
 | Name | Description
Public property | DefaultExistingFileBehavior | This property specifies the behavior of the file transfer when transferring a file that is already present in destination folder.
Public property | FileTransferTimeout | This is the maximum time in milliseconds that the file transfer can wait the completion.
Public property | IsConnected | Test whether the service is connected or not.
Public property | IsDisconnected |
Public property | IsWaitingAuthorization |
Top
See Also

Reference

ManagementService Class


ManagementService.DefaultExistingFileBehavior Property

ManagementServiceDefaultExistingFileBehavior Property

This property specifies the behavior of the file transfer when transferring a file that is already present in destination folder.

Namespace: ControlCenterSDK
Assembly: ControlCenterSDK (in ControlCenterSDK.dll) Version: 11.3.30.0 (11.3.030)
Syntax
C#
Copy
public FileTransferBehavior DefaultExistingFileBehavior { get; set; }

Property Value

Type: FileTransferBehavior
See Also

Reference

ManagementService Class


ManagementService.FileTransferTimeout Property

ManagementServiceFileTransferTimeout Property

This is the maximum time in milliseconds that the file transfer can wait the completion.

Namespace: ControlCenterSDK
Assembly: ControlCenterSDK (in ControlCenterSDK.dll) Version: 11.3.30.0 (11.3.030)
Syntax
C#
Copy
public int FileTransferTimeout { get; set; }

Property Value

Type: Int32
Remarks
If an infinite timeout is needed, you can use: Infinite.
See Also

Reference

ManagementService Class


ManagementService.IsConnected Property

ManagementServiceIsConnected Property

Test whether the service is connected or not.

Namespace: ControlCenterSDK
Assembly: ControlCenterSDK (in ControlCenterSDK.dll) Version: 11.3.30.0 (11.3.030)
Syntax
C#
Copy
public bool IsConnected { get; }

Property Value

Type: Boolean

Implements

IServiceIsConnected
See Also

Reference

ManagementService Class


ManagementService.IsDisconnected Property

ManagementServiceIsDisconnected Property

[Missing <summary> documentation for "P:ControlCenterSDK.ManagementService.IsDisconnected"]

Namespace: ControlCenterSDK
Assembly: ControlCenterSDK (in ControlCenterSDK.dll) Version: 11.3.30.0 (11.3.030)
Syntax
C#
Copy
public bool IsDisconnected { get; }

Property Value

Type: Boolean
See Also

Reference

ManagementService Class


ManagementService.IsWaitingAuthorization Property

ManagementServiceIsWaitingAuthorization Property

[Missing <summary> documentation for "P:ControlCenterSDK.ManagementService.IsWaitingAuthorization"]

Namespace: ControlCenterSDK
Assembly: ControlCenterSDK (in ControlCenterSDK.dll) Version: 11.3.30.0 (11.3.030)
Syntax
C#
Copy
public bool IsWaitingAuthorization { get; }

Property Value

Type: Boolean
See Also

Reference

ManagementService Class


ManagementService Methods

The ManagementService type exposes the following members.

Methods
 | Name | Description
Public method | AddDeviceSessionComment | Set the connection comment.
Public method | Connect | Connect the service. Can be called multiple times safely.
Public method | CreateFolder | Create a folder in the remote file system.
Public method | Delete | Delete a remote file or folder.
Public method | Disconnect | Disconnect the service. Can be called multiple times safely.
Public method | Download | Download a list of files or folders from a remote folder to a local one.
Public method | DownloadDirectoryContent | Download all the files and folders located in a remote folder to a local one.
Public method | ExecuteRemoteProcess | Execute a process.
Public method | GetAvailableDiskMB | Obtains the available disk space on the device
Public method | GetProcessList | Get the list of processes that are currently executing in the device.
Public method | GetSystemTemporaryDirectory | Tries to get the system temporary directory of the remote device
Public method | KillProcess(String) | Kill a process executing in the device.
Public method | KillProcess(ProcessInfo) | Kill a process executing in the device.
Public method | OnConnectionRefused |
Public method | Reboot | Reboot the device.
Public method | Rename | Rename a file or folder.
Public method | Upload | Upload a list of files or folders from a local folder to a remote one.
Top
See Also

Reference

ManagementService Class


ManagementService.AddDeviceSessionComment Method

ManagementServiceAddDeviceSessionComment Method

Set the connection comment.

Namespace: ControlCenterSDK
Assembly: ControlCenterSDK (in ControlCenterSDK.dll) Version: 11.3.30.0 (11.3.030)
Syntax
C#
Copy
public void AddDeviceSessionComment(
    string comment
)

Parameters

comment
Type: SystemString
the comment of the connection.
See Also

Reference

ManagementService Class


ManagementService.Connect Method

ManagementServiceConnect Method

Connect the service. Can be called multiple times safely.

Namespace: ControlCenterSDK
Assembly: ControlCenterSDK (in ControlCenterSDK.dll) Version: 11.3.30.0 (11.3.030)
Syntax
C#
Copy
public void Connect()

Implements

IServiceConnect
See Also

Reference

ManagementService Class


ManagementService.CreateFolder Method

ManagementServiceCreateFolder Method

Create a folder in the remote file system.

Namespace: ControlCenterSDK
Assembly: ControlCenterSDK (in ControlCenterSDK.dll) Version: 11.3.30.0 (11.3.030)
Syntax
C#
Copy
public void CreateFolder(
    string path,
    string folderName
)

Parameters

path
Type: SystemString
the path to the folder in which create the new folder
folderName
Type: SystemString
the name of the directory to create
See Also

Reference

ManagementService Class


ManagementService.Delete Method

ManagementServiceDelete Method

Delete a remote file or folder.

Namespace: ControlCenterSDK
Assembly: ControlCenterSDK (in ControlCenterSDK.dll) Version: 11.3.30.0 (11.3.030)
Syntax
C#
Copy
public void Delete(
    string path
)

Parameters

path
Type: SystemString
the path to the file or folder to delete
See Also

Reference

ManagementService Class


ManagementService.Disconnect Method

ManagementServiceDisconnect Method

Disconnect the service. Can be called multiple times safely.

Namespace: ControlCenterSDK
Assembly: ControlCenterSDK (in ControlCenterSDK.dll) Version: 11.3.30.0 (11.3.030)
Syntax
C#
Copy
public void Disconnect()

Implements

IServiceDisconnect
See Also

Reference

ManagementService Class


ManagementService.Download Method

ManagementServiceDownload Method

Download a list of files or folders from a remote folder to a local one.

Namespace: ControlCenterSDK
Assembly: ControlCenterSDK (in ControlCenterSDK.dll) Version: 11.3.30.0 (11.3.030)
Syntax
C#
Copy
public void Download(
    string remoteSourcePath,
    string[] filesOrFolders,
    string localDestPath
)

Parameters

remoteSourcePath
Type: SystemString
the remote folder in which source elements are located
filesOrFolders
Type: SystemString
the list of files or folder to download
localDestPath
Type: SystemString
the local destination path in which download the selected files and folders
See Also

Reference

ManagementService Class


ManagementService.DownloadDirectoryContent Method

ManagementServiceDownloadDirectoryContent Method

Download all the files and folders located in a remote folder to a local one.

Namespace: ControlCenterSDK
Assembly: ControlCenterSDK (in ControlCenterSDK.dll) Version: 11.3.30.0 (11.3.030)
Syntax
C#
Copy
public void DownloadDirectoryContent(
    string remoteSourcePath,
    string localDestPath
)

Parameters

remoteSourcePath
Type: SystemString
the remote folder to download
localDestPath
Type: SystemString
the destination folder in the local filesystem
See Also

Reference

ManagementService Class


ManagementService.ExecuteRemoteProcess Method

ManagementServiceExecuteRemoteProcess Method

Execute a process.

Namespace: ControlCenterSDK
Assembly: ControlCenterSDK (in ControlCenterSDK.dll) Version: 11.3.30.0 (11.3.030)
Syntax
C#
Copy
public void ExecuteRemoteProcess(
    string exePath,
    string arguments = null
)

Parameters

exePath
Type: SystemString
the path to the executable in the device
arguments (Optional)
Type: SystemString
the command line arguments to the executable, if needed
See Also

Reference

ManagementService Class


ManagementService.GetAvailableDiskMB Method

ManagementServiceGetAvailableDiskMB Method

Obtains the available disk space on the device

Namespace: ControlCenterSDK
Assembly: ControlCenterSDK (in ControlCenterSDK.dll) Version: 11.3.30.0 (11.3.030)
Syntax
C#
Copy
public uint GetAvailableDiskMB()

Return Value

Type: UInt32

[Missing <returns> documentation for "M:ControlCenterSDK.ManagementService.GetAvailableDiskMB"]

See Also

Reference

ManagementService Class


ManagementService.GetProcessList Method

ManagementServiceGetProcessList Method

Get the list of processes that are currently executing in the device.

Namespace: ControlCenterSDK
Assembly: ControlCenterSDK (in ControlCenterSDK.dll) Version: 11.3.30.0 (11.3.030)
Syntax
C#
Copy
public List<ProcessInfo> GetProcessList()

Return Value

Type: List ProcessInfo
the list of processes
See Also

Reference

ManagementService Class


ManagementService.GetSystemTemporaryDirectory Method

ManagementServiceGetSystemTemporaryDirectory Method

Tries to get the system temporary directory of the remote device

Namespace: ControlCenterSDK
Assembly: ControlCenterSDK (in ControlCenterSDK.dll) Version: 11.3.30.0 (11.3.030)
Syntax
C#
Copy
public string GetSystemTemporaryDirectory()

Return Value

Type: String
the system temporary directory.
See Also

Reference

ManagementService Class


ManagementService.KillProcess Method

ManagementServiceKillProcess Method

Overload List
 | Name | Description
Public method | KillProcess(String) | Kill a process executing in the device.
Public method | KillProcess(ProcessInfo) | Kill a process executing in the device.
Top
See Also

Reference

ManagementService Class


ManagementService.KillProcess Method (String)

ManagementServiceKillProcess Method (String)

Kill a process executing in the device.

Namespace: ControlCenterSDK
Assembly: ControlCenterSDK (in ControlCenterSDK.dll) Version: 11.3.30.0 (11.3.030)
Syntax
C#
Copy
public void KillProcess(
    string processName
)

Parameters

processName
Type: SystemString
the name of the process to kill
See Also

Reference

ManagementService Class
KillProcess Overload


ManagementService.KillProcess Method (ProcessInfo)

ManagementServiceKillProcess Method (ProcessInfo)

Kill a process executing in the device.

Namespace: ControlCenterSDK
Assembly: ControlCenterSDK (in ControlCenterSDK.dll) Version: 11.3.30.0 (11.3.030)
Syntax
C#
Copy
public void KillProcess(
    ProcessInfo p
)

Parameters

p
Type: ControlCenterSDKProcessInfo
the process to kill
See Also

Reference

ManagementService Class
KillProcess Overload


ManagementService.OnConnectionRefused Method

ManagementServiceOnConnectionRefused Method

[Missing <summary> documentation for "M:ControlCenterSDK.ManagementService.OnConnectionRefused"]

Namespace: ControlCenterSDK
Assembly: ControlCenterSDK (in ControlCenterSDK.dll) Version: 11.3.30.0 (11.3.030)
Syntax
C#
Copy
public void OnConnectionRefused()
See Also

Reference

ManagementService Class


ManagementService.Reboot Method

ManagementServiceReboot Method

Reboot the device.

Namespace: ControlCenterSDK
Assembly: ControlCenterSDK (in ControlCenterSDK.dll) Version: 11.3.30.0 (11.3.030)
Syntax
C#
Copy
public void Reboot()
See Also

Reference

ManagementService Class


ManagementService.Rename Method

ManagementServiceRename Method

Rename a file or folder.

Namespace: ControlCenterSDK
Assembly: ControlCenterSDK (in ControlCenterSDK.dll) Version: 11.3.30.0 (11.3.030)
Syntax
C#
Copy
public void Rename(
    string path,
    string newName
)

Parameters

path
Type: SystemString
the path to file or folder to rename.
newName
Type: SystemString
the new name for the file.
See Also

Reference

ManagementService Class


ManagementService.Upload Method

ManagementServiceUpload Method

Upload a list of files or folders from a local folder to a remote one.

Namespace: ControlCenterSDK
Assembly: ControlCenterSDK (in ControlCenterSDK.dll) Version: 11.3.30.0 (11.3.030)
Syntax
C#
Copy
public void Upload(
    string localSourcePath,
    string[] filesOrFolders,
    string remoteDestPath
)

Parameters

localSourcePath
Type: SystemString
the local folder in which source elements are located
filesOrFolders
Type: SystemString
the list of files or folder to upload
remoteDestPath
Type: SystemString
the remote destination path in which upload the selected files and folders
See Also

Reference

ManagementService Class


ProcessInfo Class

The informations of a process executing in a remote device.
Inheritance Hierarchy
SystemObject
ControlCenterSDKProcessInfo

Namespace: ControlCenterSDK
Assembly: ControlCenterSDK (in ControlCenterSDK.dll) Version: 11.3.30.0 (11.3.030)
Syntax
C#
Copy
public class ProcessInfo

The ProcessInfo type exposes the following members.

Constructors
 | Name | Description
Public method | ProcessInfo | Initializes a new instance of the ProcessInfo class
Top
Properties
 | Name | Description
Public property | CpuUsage | The CPU usage.
Public property | MemoryUsage | The memory usage in bytes.
Public property | Name | The name of the executable.
Top
See Also

Reference

ControlCenterSDK Namespace


ProcessInfo Constructor

Initializes a new instance of the ProcessInfo class

Namespace: ControlCenterSDK
Assembly: ControlCenterSDK (in ControlCenterSDK.dll) Version: 11.3.30.0 (11.3.030)
Syntax
C#
Copy
public ProcessInfo()
See Also

Reference

ProcessInfo Class


ProcessInfo Properties

The ProcessInfo type exposes the following members.

Properties
 | Name | Description
Public property | CpuUsage | The CPU usage.
Public property | MemoryUsage | The memory usage in bytes.
Public property | Name | The name of the executable.
Top
See Also

Reference

ProcessInfo Class


ProcessInfo.CpuUsage Property

ProcessInfoCpuUsage Property

The CPU usage.

Namespace: ControlCenterSDK
Assembly: ControlCenterSDK (in ControlCenterSDK.dll) Version: 11.3.30.0 (11.3.030)
Syntax
C#
Copy
public float CpuUsage { get; }

Property Value

Type: Single
See Also

Reference

ProcessInfo Class


ProcessInfo.MemoryUsage Property

ProcessInfoMemoryUsage Property

The memory usage in bytes.

Namespace: ControlCenterSDK
Assembly: ControlCenterSDK (in ControlCenterSDK.dll) Version: 11.3.30.0 (11.3.030)
Syntax
C#
Copy
public uint MemoryUsage { get; }

Property Value

Type: UInt32
See Also

Reference

ProcessInfo Class


ProcessInfo.Name Property

ProcessInfoName Property

The name of the executable.

Namespace: ControlCenterSDK
Assembly: ControlCenterSDK (in ControlCenterSDK.dll) Version: 11.3.30.0 (11.3.030)
Syntax
C#
Copy
public string Name { get; }

Property Value

Type: String
See Also

Reference

ProcessInfo Class


SDKException Class

Main exception class for SDK.
Inheritance Hierarchy
SystemObject
SystemException
ControlCenterSDKSDKException
ControlCenterSDKInvalidLoginException

Namespace: ControlCenterSDK
Assembly: ControlCenterSDK (in ControlCenterSDK.dll) Version: 11.3.30.0 (11.3.030)
Syntax
C#
Copy
public class SDKException : Exception
Constructors
 | Name | Description
Public method | SDKException | Initializes a new instance of the exception class.
Public method | SDKException(String) | Initializes a new instance of the exception class with a specified error message.
Public method | SDKException(String, Exception) | Initializes a new instance of the exception class with a specified error message and a reference to the inner exception that is the cause of this exception.
Top
See Also

Reference

ControlCenterSDK Namespace


SDKException Constructor

Overload List
 | Name | Description
Public method | SDKException | Initializes a new instance of the exception class.
Public method | SDKException(String) | Initializes a new instance of the exception class with a specified error message.
Public method | SDKException(String, Exception) | Initializes a new instance of the exception class with a specified error message and a reference to the inner exception that is the cause of this exception.
Top
See Also

Reference

SDKException Class


SDKException Constructor

Initializes a new instance of the exception class.

Namespace: ControlCenterSDK
Assembly: ControlCenterSDK (in ControlCenterSDK.dll) Version: 11.3.30.0 (11.3.030)
Syntax
C#
Copy
public SDKException()
See Also

Reference

SDKException Class
SDKException Overload


SDKException Constructor (String)

Initializes a new instance of the exception class with a specified error message.

Namespace: ControlCenterSDK
Assembly: ControlCenterSDK (in ControlCenterSDK.dll) Version: 11.3.30.0 (11.3.030)
Syntax
C#
Copy
public SDKException(
    string message
)

Parameters

message
Type: SystemString
The message that describes the error.
See Also

Reference

SDKException Class
SDKException Overload


SDKException Constructor (String, Exception)

Initializes a new instance of the exception class with a specified error message and a reference to the inner exception that is the cause of this exception.

Namespace: ControlCenterSDK
Assembly: ControlCenterSDK (in ControlCenterSDK.dll) Version: 11.3.30.0 (11.3.030)
Syntax
C#
Copy
public SDKException(
    string message,
    Exception innerException
)

Parameters

message
Type: SystemString
The error message that explains the reason for the exception.
innerException
Type: SystemException
The exception that is the cause of the current exception, or a null reference if no inner exception is specified.
See Also

Reference

SDKException Class
SDKException Overload


SerialPasstroughService Class

This service provides access to the remote serial passtrough.
Inheritance Hierarchy
SystemObject
ControlCenterSDKSerialPasstroughService

Namespace: ControlCenterSDK
Assembly: ControlCenterSDK (in ControlCenterSDK.dll) Version: 11.3.30.0 (11.3.030)
Syntax
C#
Copy
public class SerialPasstroughService : IService

The SerialPasstroughService type exposes the following members.

Properties
 | Name | Description
Public property | BaudRate | Specifies the baud rate of the serial port.
Public property | DataBits | Specifies the data bits of the serial port.
Public property | Encapsulation | Specifies the encapsulation type to be used.
Public property | FlowControl | Specifies the flow control type to be used for the serial port.
Public property | IsConnected | Test whether the service is connected or not.
Public property | LocalPort | The local virtual COM port to be used.
Public property | Parity | Specifies the parity bit of the serial port.
Public property | RemotePort | The COM port to be used in the remote device.
Public property | StopBits | Specifies the number of stop bits of the serial port.
Top
Methods
 | Name | Description
Public method | Connect | Connect the service. Can be called multiple times safely.
Public method | Disconnect | Disconnect the service. Can be called multiple times safely.
Top
Thread Safety
Instance members of this type are not safe for multi-threaded operations.
See Also

Reference

ControlCenterSDK Namespace


SerialPasstroughService Properties

The SerialPasstroughService type exposes the following members.

Properties
 | Name | Description
Public property | BaudRate | Specifies the baud rate of the serial port.
Public property | DataBits | Specifies the data bits of the serial port.
Public property | Encapsulation | Specifies the encapsulation type to be used.
Public property | FlowControl | Specifies the flow control type to be used for the serial port.
Public property | IsConnected | Test whether the service is connected or not.
Public property | LocalPort | The local virtual COM port to be used.
Public property | Parity | Specifies the parity bit of the serial port.
Public property | RemotePort | The COM port to be used in the remote device.
Public property | StopBits | Specifies the number of stop bits of the serial port.
Top
See Also

Reference

SerialPasstroughService Class


SerialPasstroughService.BaudRate Property

SerialPasstroughServiceBaudRate Property

Specifies the baud rate of the serial port.

Namespace: ControlCenterSDK
Assembly: ControlCenterSDK (in ControlCenterSDK.dll) Version: 11.3.30.0 (11.3.030)
Syntax
C#
Copy
public int BaudRate { get; set; }

Property Value

Type: Int32
Allowed values are: 110, 300, 600, 1200, 2400, 4800, 9600, 14400, 19200, 38400, 56000, 57600, 115200, 128000, 256000.
Remarks
This option is used only if EncapsulationType is DataOnly.
See Also

Reference

SerialPasstroughService Class


SerialPasstroughService.DataBits Property

SerialPasstroughServiceDataBits Property

Specifies the data bits of the serial port.

Namespace: ControlCenterSDK
Assembly: ControlCenterSDK (in ControlCenterSDK.dll) Version: 11.3.30.0 (11.3.030)
Syntax
C#
Copy
public int DataBits { get; set; }

Property Value

Type: Int32
Allowed options are 5, 6, 7, 8.
Remarks
This option is used only if EncapsulationType is DataOnly.
See Also

Reference

SerialPasstroughService Class


SerialPasstroughService.Encapsulation Property

SerialPasstroughServiceEncapsulation Property

Specifies the encapsulation type to be used.

Namespace: ControlCenterSDK
Assembly: ControlCenterSDK (in ControlCenterSDK.dll) Version: 11.3.30.0 (11.3.030)
Syntax
C#
Copy
public EncapsulationType Encapsulation { get; set; }

Property Value

Type: EncapsulationType
Remarks
If it is set to DataOnly, also BaudRate, DataBits, Parity, StopBits and FlowControl have to be specified.
See Also

Reference

SerialPasstroughService Class


SerialPasstroughService.FlowControl Property

SerialPasstroughServiceFlowControl Property

Specifies the flow control type to be used for the serial port.

Namespace: ControlCenterSDK
Assembly: ControlCenterSDK (in ControlCenterSDK.dll) Version: 11.3.30.0 (11.3.030)
Syntax
C#
Copy
public FlowControlType FlowControl { get; set; }

Property Value

Type: FlowControlType
See Also

Reference

SerialPasstroughService Class


SerialPasstroughService.IsConnected Property

SerialPasstroughServiceIsConnected Property

Test whether the service is connected or not.

Namespace: ControlCenterSDK
Assembly: ControlCenterSDK (in ControlCenterSDK.dll) Version: 11.3.30.0 (11.3.030)
Syntax
C#
Copy
public bool IsConnected { get; }

Property Value

Type: Boolean

Implements

IServiceIsConnected
See Also

Reference

SerialPasstroughService Class


SerialPasstroughService.LocalPort Property

SerialPasstroughServiceLocalPort Property

The local virtual COM port to be used.

Namespace: ControlCenterSDK
Assembly: ControlCenterSDK (in ControlCenterSDK.dll) Version: 11.3.30.0 (11.3.030)
Syntax
C#
Copy
public string LocalPort { get; set; }

Property Value

Type: String
See Also

Reference

SerialPasstroughService Class


SerialPasstroughService.Parity Property

SerialPasstroughServiceParity Property

Specifies the parity bit of the serial port.

Namespace: ControlCenterSDK
Assembly: ControlCenterSDK (in ControlCenterSDK.dll) Version: 11.3.30.0 (11.3.030)
Syntax
C#
Copy
public Parity Parity { get; set; }

Property Value

Type: Parity
Remarks
This option is used only if EncapsulationType is DataOnly.
See Also

Reference

SerialPasstroughService Class


SerialPasstroughService.RemotePort Property

SerialPasstroughServiceRemotePort Property

The COM port to be used in the remote device.

Namespace: ControlCenterSDK
Assembly: ControlCenterSDK (in ControlCenterSDK.dll) Version: 11.3.30.0 (11.3.030)
Syntax
C#
Copy
public string RemotePort { get; set; }

Property Value

Type: String
See Also

Reference

SerialPasstroughService Class


SerialPasstroughService.StopBits Property

SerialPasstroughServiceStopBits Property

Specifies the number of stop bits of the serial port.

Namespace: ControlCenterSDK
Assembly: ControlCenterSDK (in ControlCenterSDK.dll) Version: 11.3.30.0 (11.3.030)
Syntax
C#
Copy
public StopBits StopBits { get; set; }

Property Value

Type: StopBits
Remarks
This option is used only if EncapsulationType is DataOnly.
See Also

Reference

SerialPasstroughService Class


SerialPasstroughService Methods

The SerialPasstroughService type exposes the following members.

Methods
 | Name | Description
Public method | Connect | Connect the service. Can be called multiple times safely.
Public method | Disconnect | Disconnect the service. Can be called multiple times safely.
Top
See Also

Reference

SerialPasstroughService Class


SerialPasstroughService.Connect Method

SerialPasstroughServiceConnect Method

Connect the service. Can be called multiple times safely.

Namespace: ControlCenterSDK
Assembly: ControlCenterSDK (in ControlCenterSDK.dll) Version: 11.3.30.0 (11.3.030)
Syntax
C#
Copy
public void Connect()

Implements

IServiceConnect
See Also

Reference

SerialPasstroughService Class


SerialPasstroughService.Disconnect Method

SerialPasstroughServiceDisconnect Method

Disconnect the service. Can be called multiple times safely.

Namespace: ControlCenterSDK
Assembly: ControlCenterSDK (in ControlCenterSDK.dll) Version: 11.3.30.0 (11.3.030)
Syntax
C#
Copy
public void Disconnect()

Implements

IServiceDisconnect
See Also

Reference

SerialPasstroughService Class


VPNService Class

This service can be used to connect the VPN to a device.
Inheritance Hierarchy
SystemObject
ControlCenterSDKVPNService

Namespace: ControlCenterSDK
Assembly: ControlCenterSDK (in ControlCenterSDK.dll) Version: 11.3.30.0 (11.3.030)
Syntax
C#
Copy
public class VPNService : IService

The VPNService type exposes the following members.

Properties
 | Name | Description
Public property | AllowMultipleLocalVPNAddresses | Tests whether or not the device supports a client with multiple VPN IP addresses.
Public property | DesiredLocalVPNAddresses | This is the list of desired IP addresses and masks to be used as local addresses, when the VPN is connected.
Public property | IsConnected | Test whether the service is connected or not.
Public property | LocalVPNAddressAssignmentMode | Specifies whether the local VPN address should be automatically or manually assigned.
Public property | LocalVPNAddresses | The list of addresses associated with the local machine, when the VPN is connected.
Top
Methods
 | Name | Description
Public method | Connect | Connect the service. Can be called multiple times safely.
Public method | Disconnect | Disconnect the service. Can be called multiple times safely.
Top
Remarks
If you do not specify custom settings before Connect, the Control Center settings are used. This is the recommended way to go. You can also override the settings by using the properties provided by this class.
Examples
Example on how to connect the VPN to device "Device1" inside folder "Production".
C#
Copy
using (Domain domain = new Domain("MyDomain");
{
    domain.Connect("user", "password");
    Device device = domain.ConnectDevice(domain.GetDevice(@"Production\Device1"));
    device.VPN.Connect();
    // here you can use the VPN
    // ...
    device.Dispose();
}
See Also

Reference

ControlCenterSDK Namespace


VPNService Properties

The VPNService type exposes the following members.

Properties
 | Name | Description
Public property | AllowMultipleLocalVPNAddresses | Tests whether or not the device supports a client with multiple VPN IP addresses.
Public property | DesiredLocalVPNAddresses | This is the list of desired IP addresses and masks to be used as local addresses, when the VPN is connected.
Public property | IsConnected | Test whether the service is connected or not.
Public property | LocalVPNAddressAssignmentMode | Specifies whether the local VPN address should be automatically or manually assigned.
Public property | LocalVPNAddresses | The list of addresses associated with the local machine, when the VPN is connected.
Top
See Also

Reference

VPNService Class


VPNService.AllowMultipleLocalVPNAddresses Property

VPNServiceAllowMultipleLocalVPNAddresses Property

Tests whether or not the device supports a client with multiple VPN IP addresses.

Namespace: ControlCenterSDK
Assembly: ControlCenterSDK (in ControlCenterSDK.dll) Version: 11.3.30.0 (11.3.030)
Syntax
C#
Copy
public bool AllowMultipleLocalVPNAddresses { get; }

Property Value

Type: Boolean
See Also

Reference

VPNService Class


VPNService.DesiredLocalVPNAddresses Property

VPNServiceDesiredLocalVPNAddresses Property

This is the list of desired IP addresses and masks to be used as local addresses, when the VPN is connected.

Namespace: ControlCenterSDK
Assembly: ControlCenterSDK (in ControlCenterSDK.dll) Version: 11.3.30.0 (11.3.030)
Syntax
C#
Copy
public List<AddressAndMask> DesiredLocalVPNAddresses { get; }

Property Value

Type: List AddressAndMask
Remarks
Setting multiple IP addresses is supported only if AllowMultipleLocalVPNAddresses is true.
See Also

Reference

VPNService Class


VPNService.IsConnected Property

VPNServiceIsConnected Property

Test whether the service is connected or not.

Namespace: ControlCenterSDK
Assembly: ControlCenterSDK (in ControlCenterSDK.dll) Version: 11.3.30.0 (11.3.030)
Syntax
C#
Copy
public bool IsConnected { get; }

Property Value

Type: Boolean

Implements

IServiceIsConnected
See Also

Reference

VPNService Class


VPNService.LocalVPNAddressAssignmentMode Property

VPNServiceLocalVPNAddressAssignmentMode Property

Specifies whether the local VPN address should be automatically or manually assigned.

Namespace: ControlCenterSDK
Assembly: ControlCenterSDK (in ControlCenterSDK.dll) Version: 11.3.30.0 (11.3.030)
Syntax
C#
Copy
public IPAssignmentMode LocalVPNAddressAssignmentMode { get; set; }

Property Value

Type: IPAssignmentMode
Remarks
If this property is set to Manual, the property DesiredLocalVPNAddresses have to be used to specify the desired local VPN address (or addresses).
See Also

Reference

VPNService Class


VPNService.LocalVPNAddresses Property

VPNServiceLocalVPNAddresses Property

The list of addresses associated with the local machine, when the VPN is connected.

Namespace: ControlCenterSDK
Assembly: ControlCenterSDK (in ControlCenterSDK.dll) Version: 11.3.30.0 (11.3.030)
Syntax
C#
Copy
public List<AddressAndMask> LocalVPNAddresses { get; }

Property Value

Type: List AddressAndMask
See Also

Reference

VPNService Class


VPNService Methods

The VPNService type exposes the following members.

Methods
 | Name | Description
Public method | Connect | Connect the service. Can be called multiple times safely.
Public method | Disconnect | Disconnect the service. Can be called multiple times safely.
Top
See Also

Reference

VPNService Class


VPNService.Connect Method

VPNServiceConnect Method

Connect the service. Can be called multiple times safely.

Namespace: ControlCenterSDK
Assembly: ControlCenterSDK (in ControlCenterSDK.dll) Version: 11.3.30.0 (11.3.030)
Syntax
C#
Copy
public void Connect()

Implements

IServiceConnect
See Also

Reference

VPNService Class


VPNService.Disconnect Method

VPNServiceDisconnect Method

Disconnect the service. Can be called multiple times safely.

Namespace: ControlCenterSDK
Assembly: ControlCenterSDK (in ControlCenterSDK.dll) Version: 11.3.30.0 (11.3.030)
Syntax
C#
Copy
public void Disconnect()

Implements

IServiceDisconnect
See Also

Reference

VPNService Class